Bug 47779 - first time hang after fresh install
first time hang after fresh install
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-07-07 10:34 EDT by Gene Czarcinski
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-19 16:45:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-07-07 10:34:00 EDT
Description of Problem:
After a fresh (custom) install of fairfax beta1, I logged on as root and
added two users with the 'useradd" command.  This system has both gnome and
kde installed and uses gdm as the gui login.  I logged out as root and
tried to login a a new user.  Gdm disappeared and I got a grey screen hang.
 I did a <ctl-alt-backspace> to kill the window.  Logged in a root and did
a kill -HUP for the gconfd and oafd processes.  Then did a kill -HUP for
gdm --- the gdm gui screen came up.  I logged in as the same user ...
everything worked.  I logged in as a second new user ... everything OK.

This 'hang" has also occured with kde as the first login.

This does not occur for root.

How Reproducible:
Very -- but only the first time for a new user just defined.

Steps to Reproduce:
<see above>

Actual Results:
Hang thefirst time.

Expected Results:
No hang.

Additional Information:
Comment 1 Havoc Pennington 2001-07-12 11:53:14 EDT
I believe this happens, but it doesn't happen for me. How long did you wait before 
deciding it was stuck?
Comment 2 Glen Foster 2001-07-13 15:45:27 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 3 Gene Czarcinski 2001-07-14 10:24:14 EDT
I have gotten the "hang" to repeat (and not after a fresh install).

1. I did a fresh install and after reboot added three users with "useradd" and
set passwords with passwd.

2. Logoff root and login as a user -- gdm "fails" immediately and I get the gdm
screen.  I try again and this time get in.  I think this is it.

3. The next day, I rebooted the system (forget to shut it does so the filesystem
had to be checked).  I then tried to to login as a user with session selected as
"kde" -- HANG!

4.  I bounce to vt1 and login as root.  Do a "ps ax" which shows that
"/usr/bin/gdmlogin --disable-sound --disable-crash-dialog" is clocking time.  I
gave up at about 3 minutes and <ctl-alt-backspace> to kill the hung panel and
did kill -HUP for gdm itself.  When gdm restart, I was able to login fine.
Comment 4 Havoc Pennington 2001-07-18 16:11:02 EDT
Any /var/log/messages or /var/log/gdm/* stuff after this happens?
(Older versions of gdm also logged to /var/gdm I think)
Comment 5 Gene Czarcinski 2001-07-19 16:45:46 EDT
I have been unable to reproduce this on beta2.

We can either let it drop or I can dig out the beta1 cdroms, reinstall and
continue testing.
Comment 6 Havoc Pennington 2001-07-19 17:16:09 EDT
I believe we upgraded gdm from beta1 to beta2, so it is quite possibly fixed. 
Why don't we tentatively close the bug, and if it reappears reopen or I'm sure
someone else will find it and file a report.

Note You need to log in before you can comment on or make changes to this bug.