Bug 4778 - Cannot run setterm from rc.local
Cannot run setterm from rc.local
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-30 04:23 EDT by giulioo
Modified: 2014-03-16 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 16:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 1999-08-30 04:23:53 EDT
Stock rh60.

Problem:
Cannot use certain commands in rc.local due to initlog
output redirection.

We switched from caldera to rh.
We used to put "/usr/bin/setterm -blank 0 " in rc.local to
avoid console blanking.
This doesn't work in rh6 because:
1) setterm does its jobs via some control chars it sends to
the screen
2) rc.local is executed through action/initlog which does
something weird with output.
3) in init.d/funcions: INITLOG_ARGS="-q", -q is an
undocumented initlog switch (at least in the initlog man
page)

To solve this I had to put:
--
# (daemon
--
somewhere in rc.local, so that rc runs it directly instead
of through action/initlog.
rc does
--
 if egrep -q "(daemon |action )" $i ; then
--
to decide how to run a script; by putting "(daemon" in
rc.local I made rc to run rc.local as
rc.local start
instead of
action "bla bla" rc.local start

This way "setterm" does its job ok.

Regards.
Comment 1 Bill Nottingham 1999-09-20 16:36:59 EDT
fixed in initscripts-4.44-1; rc.local is not run through initlog
any more.

Note You need to log in before you can comment on or make changes to this bug.