Bug 477800 - gnomevfssrc source element missing from gstreamer-plugins-base package
gnomevfssrc source element missing from gstreamer-plugins-base package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-base (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 14:20 EST by Lev Gelb
Modified: 2009-05-09 08:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 08:30:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lev Gelb 2008-12-23 14:20:56 EST
Description of problem:

The "gnomevfssrc" source element seems to be missing from gstreamer-plugins-base (and all other gstreamer packages)

Version-Release number of selected component (if applicable):

gstreamer-plugins-base-0.10.21-2.fc10.x86_64

How reproducible:

Very.

Steps to Reproduce:
1. execute: gst-inspect gnomevfssrc

Actual results:

No such element or plugin 'gnomevfssrc'
  
Expected results:  (from a machine running Fedora 9,  gstreamer-plugins-base-0.10.19-4.fc9.x86_64)

Factory Details:
  Long name:	GnomeVFS Source
  Class:	Source/File
  Description:	Read from any GnomeVFS-supported file
  Author(s):	Bastien Nocera <hadess@hadess.net>
Ronald S. Bultje <rbultje@ronald.bitfreak.net>
  Rank:		secondary (128)

Plugin Details:
  Name:			gnomevfs
  Description:		elements to read from and write to  Gnome-VFS uri's
  Filename:		/usr/lib64/gstreamer-0.10/libgstgnomevfs.so
  Version:		0.10.19
  License:		LGPL
  Source module:	gst-plugins-base
  Binary package:	Fedora gstreamer-plugins-base package
  Origin URL:		http://download.fedora.redhat.com/fedora


Additional info:
I don't know where its got to.  It seems to be in the upstream source tarball.
Comment 1 Lev Gelb 2009-02-02 16:25:27 EST
OK, its been more than a month - can someone please have a look at this?
Comment 2 Bastien Nocera 2009-05-09 08:30:58 EDT
This was a conscious decision, the gvfssrc/gvfssink replace the gnome-vfs ones. If an application requires either gnomevfssrc or gnomevfssink, then it will need to be fixed.

Note You need to log in before you can comment on or make changes to this bug.