Bug 477814 - bootp problem with parse_option_buffer
bootp problem with parse_option_buffer
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 16:56 EST by Rudolf Kastl
Modified: 2009-01-28 16:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 16:16:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2008-12-23 16:56:12 EST
Description of problem:
actually a problem that seems to be a regression in bootp:

dhcpd: parse_option_buffer: option nis-domain (40:32) larger than buffer

this option seems to be requested by the client as tcpdump shows:
22:10:13.609182 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 192.168.1.7, length 300
which keeps on repeating itsself.

Version-Release number of selected component (if applicable):
dhcp-4.0.0-33.fc11.i386

How reproducible:
always reproduceable with a dbox2

is there any known workaround to prevent this message and convince the dhcpd to keep going?
Comment 1 David Cantrell 2009-01-08 13:35:10 EST
I just upgraded rawhide to ISC dhcp-4.1.0, does this problem still occur with dhcp-4.1.0-1.fc11?
Comment 2 David Cantrell 2009-01-28 16:16:09 EST
Unfortunately since this is an unchangeable embedded device on the client side, there's not much I can do.

Note You need to log in before you can comment on or make changes to this bug.