Bug 477815 - [PATCH] Evolution data server crashes due to incorrect calendar URIs
[PATCH] Evolution data server crashes due to incorrect calendar URIs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2008-12-23 17:01 EST by Lubomir Rintel
Modified: 2009-01-05 08:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 08:43:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Check return values of soup_message_new() (4.07 KB, text/plain)
2008-12-23 17:01 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2008-12-23 17:01:02 EST
Created attachment 327774 [details]
Check return values of soup_message_new()

Description of problem:

Evolution data server crashes due to incorrect calendar URIs.

Version-Release number of selected component (if applicable):

Reproduced with following:

evolution-data-server-1.12.3-6.el5
evolution-data-server-2.25.3-1.fc10

How reproducible:

100%

Steps to Reproduce:
1. Create new calendar
2. Pick CalDAV
3. Pick a name, leave "caldav://" as URI
  
Actual results:

Crash.

Expected results:

Profit.

Additional info:

Patch to address the issue is attached.
Comment 1 Lubomir Rintel 2009-01-02 07:31:00 EST
Ping
Comment 2 Milan Crha 2009-01-05 08:43:10 EST
pong.

Thanks for the report, but I'm move it upstream [1], there is no need to have this included in Fedora only.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=566627

Note You need to log in before you can comment on or make changes to this bug.