Bug 477838 - Disclaimer of responsibility on test page
Disclaimer of responsibility on test page
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 21:53 EST by Tom "spot" Callaway
Modified: 2009-10-27 15:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 15:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2008-12-23 21:53:45 EST
Description of problem:

For a while now, Fedora/Red Hat has been getting some emails regarding http servers which have offended someone, broken the law, or "been hacked". All of these stem to the httpd instance not being completely setup, and the test page being either displayed or discovered. People assume that Fedora is responsible for the server, and start making various threats.

While we cannot force people to read the test page (or to simply setup httpd properly), we can add text to disclaim responsibility for the webserver.
I would humbly suggest the following text addition:

========================

Fedora is a distribution of Linux, a popular operating system alternative to Microsoft Windows. It is commonly used by hosting companies because it is free, and includes free web server software. Many times, they do not set up their web server correctly, and it displays this "test page" instead of the expected website. 

Accordingly, please keep these facts in mind:
* Neither the Fedora Project nor Red Hat has any affiliation with any website or content hosted from this server (unless otherwise explicitly stated).
* Neither the Fedora Project nor Red Hat has "hacked" this webserver, this test page is an included component of Apache's httpd webserver software.

For more information about the Fedora Project, see: 
http://fedoraproject.org/
For more information about the Apache httpd webserver software, see: http://httpd.apache.org/

========================
Comment 1 Joe Orton 2009-01-22 10:20:32 EST
This is kind of duplicating the text which is already there.  Do you really think people would be less likely to spend you-hacked-the-site spam if we add *more* text to the page?

The approach taken upstream is to reduce the page to a single line saying "It works!".  We can go that route too, if the spam is seen to be such a problem, but personally, I like the branding.
Comment 2 Tom "spot" Callaway 2009-01-22 10:27:34 EST
I like the branding too, but I'm getting almost daily emails at this point.

I think that people are reading:

"For information on Fedora, please visit the Fedora Project website." 

and drawing a conclusion that we are involved. I just want to make it painfully explicit that we are not.

The text I proposed is what I send out to people who email webmaster@fedoraproject.org or legal@fedoraproject.org, and in every case, it satisfies them (and several of them suggested that if it had been on the test page, they would not have contacted us).
Comment 3 Bug Zapper 2009-06-09 06:29:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tom "spot" Callaway 2009-10-27 15:19:11 EDT
I added similar text to the F-12 and rawhide packages. Hopefully this will minimize the incoming emails to webmaster@ and legal@.

Note You need to log in before you can comment on or make changes to this bug.