Bug 477859 - Xorg crashes when compiz-fusion is enabled, deadlocking the machine
Xorg crashes when compiz-fusion is enabled, deadlocking the machine
Status: CLOSED DUPLICATE of bug 464866
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Desktop
Depends On:
  Show dependency treegraph
Reported: 2008-12-24 07:04 EST by Eric Donkersloot
Modified: 2009-03-16 10:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-16 08:57:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg.0.log (83.67 KB, text/plain)
2009-01-25 14:49 EST, Eric Donkersloot
no flags Details
Xorg.0.log when the crash occurs (96.86 KB, application/octet-stream)
2009-01-30 15:35 EST, Eric Donkersloot
no flags Details

  None (edit)
Description Eric Donkersloot 2008-12-24 07:04:13 EST
Description of problem:

Xorg crashes after some amount of usage when compiz-fusion is enabled (xorg-x11-drv-i810 driver). This behaviour is not present when compiz-fusion is disabled.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1. Enable compiz-fusion
2. Work, browse the internet, play...whatever
3. Within 30 minutes xorg will have crashed, logging in remotely and killing xorg deadlocks the machine completely
Actual results:

When xorg crashes, I still can login remotely. However, when I try to reboot the machine or kill xorg manually, the machine deadlocks. No event is written to syslog whatsoever.

Expected results:

Normal operation

Additional info:

Sony Vaio VGN-BZ12XN
Mobile Intel 4500MHD videocard
Comment 1 Matěj Cepl 2009-01-07 09:03:13 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Jarod Wilson 2009-01-08 10:49:30 EST
Smells like a potential duplicate of bug 464866.
Comment 3 Eric Donkersloot 2009-01-25 14:49:50 EST
Created attachment 329953 [details]

There is no /etc/X11/xorg.conf presen on my system, here's the Xorg.0.log.
Comment 4 Eric Donkersloot 2009-01-30 15:35:38 EST
Created attachment 330505 [details]
Xorg.0.log when the crash occurs

This is an updated Xorg.0.log:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

0: /usr/bin/Xorg(xorg_backtrace+0x3b) [0x812bc5b]
1: /usr/bin/Xorg(mieqEnqueue+0x289) [0x810b379]
2: /usr/bin/Xorg(xf86PostMotionEventP+0xc2) [0x80d4262]
3: /usr/bin/Xorg(xf86PostMotionEvent+0x68) [0x80d43c8]
4: /usr/lib/xorg/modules/input//evdev_drv.so [0x203d25]
5: /usr/bin/Xorg [0x80bcdb7]
6: /usr/bin/Xorg [0x80ac91e]
7: [0xf5c400]
8: [0xf5c416]
9: /lib/libc.so.6(ioctl+0x19) [0x316979]
10: /usr/lib/libdrm.so.2 [0x3b3a6cf]
11: /usr/lib/libdrm.so.2(drmWaitVBlank+0x28) [0x3b3ae08]
12: /usr/lib/dri/i965_dri.so [0x199578]
13: /usr/lib/dri/i965_dri.so(driWaitForVBlank+0xd8) [0x199798]
14: /usr/lib/dri/i965_dri.so(intelSwapBuffers+0x262) [0x19f5ac]
15: /usr/lib/dri/i965_dri.so [0x199912]
16: /usr/lib/xorg/modules/extensions//libglx.so [0x153504]
17: /usr/lib/xorg/modules/extensions//libglx.so [0x145cfe]
18: /usr/lib/xorg/modules/extensions//libglx.so [0x14963a]
19: /usr/bin/Xorg(Dispatch+0x34f) [0x8085e9f]
20: /usr/bin/Xorg(main+0x47d) [0x806b71d]
21: /lib/libc.so.6(__libc_start_main+0xe5) [0x2516e5]
22: /usr/bin/Xorg [0x806ab01]
[mi] mieqEnequeue: out-of-order valuator event; dropping.
Comment 5 Eric Donkersloot 2009-01-30 15:36:55 EST
@Jarod: I think you are correct
Comment 6 Eric Donkersloot 2009-01-30 16:01:48 EST
Package versions:
Comment 7 Eric Donkersloot 2009-03-16 08:53:56 EDT
Looks like adding this option to xorg.conf solved the issue, I have been using my laptop with compiz enabled for hours now, without a crash:

Option    "ExaNoComposite"  "on"
Comment 8 Eric Donkersloot 2009-03-16 08:57:37 EDT

*** This bug has been marked as a duplicate of bug 464866 ***
Comment 9 Eric Donkersloot 2009-03-16 10:52:41 EDT
Please disregard my previous comment, I just expercienced another crash.

Note You need to log in before you can comment on or make changes to this bug.