Bug 477863 - amarokFS (from package: amarokFS-0.5-4.fc10.x86_64) uses all available memory when run
amarokFS (from package: amarokFS-0.5-4.fc10.x86_64) uses all available memory...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: amarokFS (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Francois Aucamp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-24 08:49 EST by Alex Musolino
Modified: 2009-07-27 03:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 03:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DCOP errors (1.99 KB, text/plain)
2008-12-24 08:55 EST, Alex Musolino
no flags Details

  None (edit)
Description Alex Musolino 2008-12-24 08:49:50 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc10 Firefox/3.0.5

Upon running /usr/bin/amarokFS, all memory is consumed and the system starts swapping. At this point the mouse starts to become unresponsive (extremely jerky) and the music skips (using Amarok from package: amarok-2.0-2.fc10.x86_64).

Various errors relating to DCOP are reported via stdout (when run from the command line). This is obviously because Amarok 2 does not use DCOP and so all calls fail.

I'll attach the error messages I get.

Reproducible: Always

Steps to Reproduce:
1. `yum -y install amarokFS`
2. `amarokFS`
Actual Results:  
Memory is consumed and machine starts swapping (usage increases until amarokFS is killed). No graphical activity occurs.

Expected Results:  
AmarokFS should run as a full-screen application (like this http://www.kde-apps.org/content/preview.php?preview=1&id=52641&file1=52641-1.png&file2=&file3=52641-3.png&name=Amarok+Full+Screen) and be capable of controlling a running Amarok.

If amarokFS cannot contact the DCOP server or call Amarok's DCOP functions it should print an error message saying so and terminate.

As far as I can tell amarokFS is built for Amarok 1.4.x but for some reason is included as part of Fedora 10 - for which only Amarok 2 is available. Still, I don't think it should be doing what it's doing.

Also, I'm unsure about the severity so I'll just stick with medium (though I think it could be Urgent or Low, based on the descriptions for these levels).
Comment 1 Alex Musolino 2008-12-24 08:55:27 EST
Created attachment 327811 [details]
DCOP errors

These are the errors that are sent to stdout when running amarokFS from the command line.
Comment 2 Francois Aucamp 2009-07-27 03:38:37 EDT
amarokFS is a retired package; closing this bug

Note You need to log in before you can comment on or make changes to this bug.