Bug 477888 - no sound in jack audio output after kernel upgrade
no sound in jack audio output after kernel upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-24 14:48 EST by markm
Modified: 2009-01-29 00:35 EST (History)
29 users (show)

See Also:
Fixed In Version: 2.6.27.12-170.2.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 00:35:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2008-12-24 14:48:22 EST
Description of problem:

I've just ugpraded to the latest version of kernel and lost audio in jack audio output - I can hear sound from my laptop's speakers, but I cannot use external ones.

Version-Release number of selected component (if applicable):

[marek@d620 Desktop]$ uname -a
Linux d620 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 i686 i386 GNU/Linux
[marek@d620 Desktop]$ 

my laptop: Dell Latitude D620

Steps to Reproduce:
1. upgrade to the kernel version 2.6.27.9-159.fc10.i686
2. restart computer
  
Actual results:

no sound through jack audio output

Expected results:

sound works as it used to work

Additional info:

thanks for a nice present for Christmas ;-)
Comment 1 markm 2008-12-24 15:07:01 EST
tested three times on kernel 2.6.27.9-159.fc10.i686, with the same effect. downgrade to 2.6.27.7-134.fc10.i686  solved the problem.
Comment 2 Brian Millett 2008-12-24 16:48:43 EST
Same here with a dell d820

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

40: udi = '/org/freedesktop/Hal/devices/pci_8086_27d8_sound_card_0_oss_pcm_1'
  oss.originating_device = '/org/freedesktop/Hal/devices/pci_8086_27d8_sound_card_0'  (string)
  info.subsystem = 'sound'  (string)
  info.category = 'oss'  (string)
  oss.card = 0  (0x0)  (int)
  info.product = 'STAC92xx Analog OSS PCM Device'  (string)
  info.callouts.add = { 'hal-acl-tool --add-device' } (string list)
  info.capabilities = { 'oss', 'access_control' } (string list)
  oss.card_id = 'HDA Intel'  (string)
  info.udi = '/org/freedesktop/Hal/devices/pci_8086_27d8_sound_card_0_oss_pcm_1'  (string)
  oss.device_id = 'STAC92xx Analog'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1b.0/sound/card0/adsp'  (string)
  oss.device = 1  (0x1)  (int)
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_27d8_sound_card_0'  (string)
  oss.type = 'pcm'  (string)
  access_control.file = '/dev/adsp'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  access_control.type = 'sound'  (string)
  linux.subsystem = 'sound'  (string)
  info.callouts.remove = { 'hal-acl-tool --remove-device' } (string list)
  linux.device_file = '/dev/adsp'  (string)
  oss.device_file = '/dev/adsp'  (string)

41: udi = '/org/freedesktop/Hal/devices/pci_8086_27d8_logicaldev_input'
  info.subsystem = 'input'  (string)
  info.category = 'input'  (string)
  info.product = 'HDA Intel at 0xefffc000 irq 21 HP Out at Ext Left Jack'  (string)
  info.capabilities = { 'input', 'input.switch', 'button' } (string list)
  info.udi = '/org/freedesktop/Hal/devices/pci_8086_27d8_logicaldev_input'  (string)
  button.has_state = true  (bool)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1b.0/input/input11/event11'  (string)
  input.device = '/dev/input/event11'  (string)
  button.type = 'headphone_insert'  (string)
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_27d8'  (string)
  input.product = 'HDA Intel at 0xefffc000 irq 21 HP Out at Ext Left Jack'  (string)
  button.state.value = true  (bool)
  input.originating_device = '/org/freedesktop/Hal/devices/pci_8086_27d8'  (string)
  info.addons.singleton = { 'hald-addon-input' } (string list)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'input'  (string)
  linux.device_file = '/dev/input/event11'  (string)
Comment 3 Jean-pierre Cartal 2008-12-26 02:22:58 EST
Same here with a dell d830
Comment 4 Michal Kučera 2008-12-26 04:59:50 EST
I confirm this bug on dell latitude d620 laptop. I have same problem, I had to downgrade to kernel 2.6.27.5-117.fc10.i686
Comment 5 markm 2008-12-26 05:02:49 EST
my sister is reporting that her laptop lost sound in headphones after latest kernel upgrade too, her laptop: Dell XPS M1330. Kernel downgrade solved her problem.
Comment 6 Lukas Tvrdy 2008-12-26 07:30:14 EST
I confirm this bug too.

More info:
http://forums.fedoraforum.org/showthread.php?t=208838

Downgrade to older kernel(2.6.27.7-134.fc10.i686) helped.
Comment 7 markm 2008-12-26 10:07:45 EST
just upgraded to kernel-2.6.27.10-167.fc10 from http://koji.fedoraproject.org/koji/buildinfo?buildID=76110 - problem still not solved.
Comment 8 paolo borelli 2008-12-26 10:17:26 EST
same here, dell latitude d830 (is there a way to subscribe to a bug without a "me too" comment?)
Comment 9 Yves Kondoszek 2008-12-26 10:24:47 EST
Experiencing the same problem with a DELL XPS M1530
Comment 10 Ravindra Singh 2008-12-26 15:04:38 EST
Yup Can Confirm the same issue. Running Fedora 10 on Dell 1505/6400 laptop... kernel is kernel-2.6.27.9-159.fc10.i686

Card is Sigmatel
Comment 11 Scott Williams 2008-12-26 23:41:58 EST
I am having the same issue with an Audigy 2 card with kernel kernel-2.6.27.9-159.fc10.x86_64.

The speakers pop on start up as normal but no sound after log in.  Alsa detects the card, it is listed in lspci, and volume is up.  Without changing any settings, regressing to kernel-2.6.27.7-134.fc10.x86_64 brings sounds back.

For what it's worth, I am using alsa with pulse, but since the issue is kernel related, a new bug will likely end up as a duplicate of this one.

Here's a copy of my alsa-info: http://www.alsa-project.org/db/?f=05015ec3bfcbc212b26134c5dfb02e8c6dab4f05
Comment 12 Matt McCutchen 2008-12-28 01:47:06 EST
I hit the same issue on my Dell Latitude D620.  I tried kernel-2.6.28-2.fc11.i686 from rawhide and the sound works fine; I'll use this kernel until the issue is fixed.
Comment 13 markm 2008-12-28 17:29:59 EST
(In reply to comment #12)
> I hit the same issue on my Dell Latitude D620.  I tried
> kernel-2.6.28-2.fc11.i686 from rawhide and the sound works fine; I'll use this
> kernel until the issue is fixed.

I've tried kernel 2.6.28 and it had this issue fixed, but this kernel does something naughty to nvidia graphics card and it stops working, so I had to downgrade back to 2.6.27.7-134.
Comment 14 Matt McCutchen 2008-12-28 18:29:59 EST
(In reply to comment #13)
> I've tried kernel 2.6.28 and it had this issue fixed, but this kernel does
> something naughty to nvidia graphics card and it stops working

My nvidia card is working just fine with a module built from RPM Fusion's akmod-nvidia-180.16-1.fc11.1.i686 .
Comment 15 markm 2008-12-28 19:01:09 EST
(In reply to comment #14)
> (In reply to comment #13)
> > I've tried kernel 2.6.28 and it had this issue fixed, but this kernel does
> > something naughty to nvidia graphics card and it stops working
> 
> My nvidia card is working just fine with a module built from RPM Fusion's
> akmod-nvidia-180.16-1.fc11.1.i686 .

it works fine with 2.6.27.7-134, but it's too late to test it under 2.6.28 which I suspect is causing nvidia crashes (with 177.82 nvidia crashes strightaway, with 180.16 started to behave abnormally then started to crash too).
Comment 16 Michal Kučera 2008-12-29 04:02:18 EST
I tried to run kernel 2.6.27.9-159.fc10.i686 and added option into modprobe.conf. 
I added this option: 
options snd-hda-intel model=dell-m22 

but sound in output jack still doesn't work. 

here is some output from dmesg: 

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21                                                                                           
HDA Intel 0000:00:1b.0: setting latency timer to 64                                                                                                          
ALSA sound/pci/hda/hda_codec.c:2587: hda_codec: model 'dell-m22' is selected                                                                                 
ALSA sound/pci/hda/hda_codec.c:3303: autoconfig: line_outs=1 (0xe/0x0/0x0/0x0/0x0)                                                                           
ALSA sound/pci/hda/hda_codec.c:3307:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)                                                                                 
ALSA sound/pci/hda/hda_codec.c:3311:    hp_outs=1 (0xd/0x0/0x0/0x0/0x0)                                                                                      
ALSA sound/pci/hda/hda_codec.c:3312:    mono: mono_out=0x0                                                                                                   
ALSA sound/pci/hda/hda_codec.c:3320:    inputs: mic=0xf, fmic=0x10, line=0x0, fline=0x0, cd=0x0, aux=0x0                                                     
input: HDA Intel at 0xefebc000 irq 21 HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/input/input14         

and last line in dmesg, maybe it said something: 
ALSA sound/pci/hda/hda_intel.c:623: hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x005f000a
Comment 17 Michal Kučera 2008-12-29 04:48:40 EST
If I run kernel 2.6.27.5-117.fc10.i686 with option snd-hda-intel model=dell-m22, everything works properly. Here is output from dmesg: 

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21                                                                                           
HDA Intel 0000:00:1b.0: setting latency timer to 64                                                                                                          
ALSA sound/pci/hda/hda_codec.c:2325: hda_codec: model 'dell-m22' is selected                                                                                 
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=1 (0xe/0x0/0x0/0x0/0x0)                                                                           
ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)                                                                                 
ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0xd/0x0/0x0/0x0/0x0)                                                                                      
ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0                                                                                                   
ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0xf, fmic=0x10, line=0x0, fline=0x0, cd=0x0, aux=0x0  

Everything looks like similar excluding theese lines: 
input: HDA Intel at 0xefebc000 irq 21 HP Out at Ext Left Jack as
/devices/pci0000:00/0000:00:1b.0/input/input14  

ALSA sound/pci/hda/hda_intel.c:623: hda_intel: azx_get_response timeout,
switching to polling mode: last cmd=0x005f000a
Comment 18 Michal Kučera 2008-12-29 05:12:40 EST
Here is dmesg ouput on kernel 2.6.27.9-159.fc10.i686 without option snd-hda-intel model=dell-m22

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21                                                                                           
HDA Intel 0000:00:1b.0: setting latency timer to 64                                                                                                          
ALSA sound/pci/hda/hda_codec.c:3303: autoconfig: line_outs=1 (0xe/0x0/0x0/0x0/0x0)                                                                           
ALSA sound/pci/hda/hda_codec.c:3307:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)                                                                                 
ALSA sound/pci/hda/hda_codec.c:3311:    hp_outs=1 (0xd/0x0/0x0/0x0/0x0)                                                                                      
ALSA sound/pci/hda/hda_codec.c:3312:    mono: mono_out=0x0                                                                                                   
ALSA sound/pci/hda/hda_codec.c:3320:    inputs: mic=0xf, fmic=0x10, line=0x0, fline=0x0, cd=0x0, aux=0x0                                                     
input: HDA Intel at 0xefebc000 irq 21 HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/input/input14                                              
cs: IO port probe 0x100-0x3af: clean.                                                                                                                        
cs: IO port probe 0x3e0-0x4ff: clean.                                                                                                                        
cs: IO port probe 0x820-0x8ff: clean.                                                                                                                        
cs: IO port probe 0xc00-0xcf7: clean.                                                                                                                        
cs: IO port probe 0xa00-0xaff: clean.                                                                                                                        
ALSA sound/pci/hda/hda_intel.c:623: hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x00ab8000

and dmesg output on kernel 2.6.27.5-117.fc10.i686 without option snd-hda-intel
model=dell-m22

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21                                                                                           
HDA Intel 0000:00:1b.0: setting latency timer to 64                                                                                                          
ALSA sound/pci/hda/hda_codec.c:3021: autoconfig: line_outs=1 (0xe/0x0/0x0/0x0/0x0)                                                                           
ALSA sound/pci/hda/hda_codec.c:3025:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)                                                                                 
ALSA sound/pci/hda/hda_codec.c:3029:    hp_outs=1 (0xd/0x0/0x0/0x0/0x0)                                                                                      
ALSA sound/pci/hda/hda_codec.c:3030:    mono: mono_out=0x0                                                                                                   
ALSA sound/pci/hda/hda_codec.c:3038:    inputs: mic=0xf, fmic=0x10, line=0x0, fline=0x0, cd=0x0, aux=0x0                                                     
cs: IO port probe 0x100-0x3af: clean.                                                                                                                        
cs: IO port probe 0x3e0-0x4ff: clean.                                                                                                                        
cs: IO port probe 0x820-0x8ff: clean.                                                                                                                        
cs: IO port probe 0xc00-0xcf7: clean.                                                                                                                        
cs: IO port probe 0xa00-0xaff: clean.
Comment 19 Leonid Kanter 2009-01-01 09:00:05 EST
The same problem with F9 on Dell D620 kernel 2.6.27.9-73.fc9

It could be possible that following change broke headphones:

* Tue Dec 16 2008 Chuck Ebbert <cebbert@redhat.com> 2.6.27.9-73
- Disable input beep feature in Intel HDA sound driver.
Comment 20 jonny 2009-01-01 14:53:56 EST
I have he same problem with a Dell Studio 15. With previous kernels, there was an "switches" tab in Gnome's alsa mixer which would allow me to check a box causing headphones to be used as line out, or something of that nature. Anyway, that allowed the headphones to be used, and now it does not exist.

Uname -a:
Linux jonny-laptop 2.6.27.9-159.fc10.x86_64 #1 SMP Tue Dec 16 14:47:52 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

lsmod:
snd                    70392  23 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep

lspci:
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)

dmesg:
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
HDA Intel 0000:00:1b.0: setting latency timer to 64
ALSA sound/pci/hda/hda_intel.c:623: hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x022f1c00
ALSA sound/pci/hda/hda_codec.c:3303: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3307:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3311:    hp_outs=2 (0xa/0xf/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3312:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3320:    inputs: mic=0xe, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
input: HDA Intel at 0xf6ffc000 irq 21 Mic at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/input/input12
input: HDA Intel at 0xf6ffc000 irq 21 HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/input/input13
input: HDA Intel at 0xf6ffc000 irq 21 HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/input/input14
HDA Intel 0000:01:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
HDA Intel 0000:01:00.1: setting latency timer to 64
Comment 21 John Smith 2009-01-04 13:06:15 EST
Same problem with F10, kernel version 2.6.27.9-159, on a Dell Inspiron laptop:

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
Comment 22 Everaldo de Nóbrega Peixoto 2009-01-04 20:55:02 EST
Similar problem on a Dell Precision M6300 with F10, Kernel 2.6.27.9-159.fc10.x86_64. Initially no sound at all after boot, if you connect a headphone (which will have only low noise, volume control ineffective over it) and disconnect it you will have sound , speakers only.
On the other hand, same laptop (Dell Precision M6300) running F9, Kernel 2.6.27.9-73.fc9.x86_64, no sound at all, no matter what you try to restore it.

Previous versions of kernel, for both Fedora releases, worked fine.

Follows additional information, obtained under 2.6.27.9-159.fc10.x86_64:

sudo lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

cat /proc/asound/card0/codec#0|grep -i codec:
Codec: SigmaTel STAC9205

sudo lsmod | grep snd
snd_hda_intel         533412  4 
snd_seq_dummy          11396  0 
snd_seq_oss            39104  0 
snd_seq_midi_event     14848  1 snd_seq_oss
snd_seq                61712  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         15252  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            51200  0 
snd_mixer_oss          23168  1 snd_pcm_oss
snd_pcm                84360  2 snd_hda_intel,snd_pcm_oss
snd_timer              30224  2 snd_seq,snd_pcm
snd_page_alloc         16784  2 snd_hda_intel,snd_pcm
snd_hwdep              16264  1 snd_hda_intel
snd                    70392  18 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              14992  1 snd

partial dmesg output:

HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
HDA Intel 0000:00:1b.0: setting latency timer to 64
ALSA sound/pci/hda/hda_codec.c:3303: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3307:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3311:    hp_outs=1 (0xa/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:3312:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:3320:    inputs: mic=0xb, fmic=0xc, line=0x0, fline=0x0, cd=0x0, aux=0x0
ALSA sound/pci/hda/patch_sigmatel.c:2778: dac_nids=1 (0x10/0x0/0x0/0x0/0x0)
input: HDA Intel at 0xf6ffc000 irq 21 Mic at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/input/input9
input: HDA Intel at 0xf6ffc000 irq 21 HP Out at Ext Left Jack as /devices/pci0000:00/0000:00:1b.0/input/input10
Comment 23 Agustin Barto 2009-01-07 13:34:49 EST
Same problem with a Dell Inspiron 6400 and F10's kernel 2.6.27.9-159. Fixed it installing alsa-driver from the bleeding-edge ATrpms repo.
Comment 24 Eugene Savelov 2009-01-09 02:28:36 EST
Same problem with Dell Inspiron 1501 and fedora10 latest kernel. fixed by upgrading to kernel-2.6.28-3.fc11.x86_64.rpm 
http://koji.fedoraproject.org/koji/buildinfo?buildID=76461
Comment 25 A Oepping 2009-01-09 06:00:15 EST
As reported in duplicate bug #477911 by other users I am having a similar problem in FC9 2.6.27.9-73.fc9.x86_64 with Creative Labs SB Audigy (rev 04) except I have the problem with my external speakers. I did not test my other jacks although one user reported headphone jack was working on #477911

05:00.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
	Subsystem: Creative Labs SB Audigy 2 ZS (SB0350)
	Flags: bus master, medium devsel, latency 32, IRQ 20
	I/O ports at c000 [size=64]
	Capabilities: [dc] Power Management version 2
	Kernel driver in use: EMU10K1_Audigy
	Kernel modules: snd-emu10k1


broken on 2.6.27.9-73.fc9.x86_64
works on: 2.6.27.5-41.fc9.x86_64

CPU is 2400 idle but overclocked @3600 under load. PCI bus is not overclocked.

Jan  9 02:58:40  kernel: Linux version 2.6.27.9-73.fc9.x86_64 (mockbuild@) (gcc version 4.3.0 20080428 (Red Hat 4.3.0-8) (GCC) ) #1 SMP Tue Dec 16 14:54:03 EST 2

Jan  9 02:58:40  kernel: CPU1: Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz stepping 06

Jan  9 02:58:40  kernel: firewire_ohci 0000:05:00.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
Jan  9 02:58:40  kernel: gameport: EMU10K1 is pci0000:05:00.1/gameport0, io 0xc100, speed 1052kHz
Jan  9 02:58:40  kernel: firewire_ohci: Added fw-ohci device 0000:05:00.2, OHCI version 1.10

Jan  9 02:58:40  kernel: firewire_core: created device fw0: GUID 00023c0151132525, S400
Jan  9 02:58:40  kernel: EMU10K1_Audigy 0000:05:00.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
Jan  9 02:58:40  kernel: ALSA sound/pci/emu10k1/emufx.c:1546: Installing spdif_bug patch: SB Audigy 2 ZS [SB0350]
Comment 26 Steve 2009-01-15 05:48:31 EST
Same problem on Dell Precision M90.  Downgrading to 2.6.27.7-134.fc10.i686 fixed it.
Comment 27 Matt McCutchen 2009-01-15 09:34:20 EST
The audio output is working again on my Dell Latitude D620 with kernel-2.6.28-3.fc10.i686.  This kernel is also free of some of the unrelated problems I've been hitting with recent rawhide kernels.
Comment 28 Brian Millett 2009-01-15 11:31:22 EST
I can confirm that the kernel-2.6.28-3.fc10.i686 from http://koji.fedoraproject.org/koji/buildinfo?buildID=78354

works for the audio jack problem for my dell d820.

There were previous postings about nvidia WHICH I know is not part of this bug, but with the new kernel, the nvidia akmod from rpmfusion is borked but the dkms talked about in post #3 at http://forums.fedoraforum.org/showthread.php?t=204752 works.
Comment 29 markm 2009-01-15 11:42:45 EST
(In reply to comment #28)
> I can confirm that the kernel-2.6.28-3.fc10.i686 from
> http://koji.fedoraproject.org/koji/buildinfo?buildID=78354
> 
> works for the audio jack problem for my dell d820.
> 
> There were previous postings about nvidia WHICH I know is not part of this bug,
> but with the new kernel, the nvidia akmod from rpmfusion is borked but the dkms
> talked about in post #3 at
> http://forums.fedoraforum.org/showthread.php?t=204752 works.

I've tried 2.6.28.fc11 from rawhide with nvidia drivers and after that I had to replace my graphics card - not sure if that was related, but it has happened on two different laptops so... I am quite scare of trying to upgrade kernel now :-)
Comment 30 Erwan LE PENNEC 2009-01-16 08:04:08 EST
I just wanted to confirm that the kernel-2.6.28-3.fc10.i686 from koji works like a charm on my dell d620... after I fix a different issue. I had to modify the kernel line in grub in order to boot successfully, I had to replace root=UUID=4...by root=root=/dev/VolGroup00/LogVol00.
Comment 31 Agustin Barto 2009-01-16 09:04:13 EST
I confirm that kernel-2.6.28-3.fc10.i686 from koji solved the problem for my Inspiron 6400.
Comment 32 Fregge 2009-01-19 07:40:41 EST
Same problem on Dell Inspiron 9400. Downgrading the kernel to 2.6.27.7 solved the problem.
Comment 33 jarki 2009-01-21 14:09:45 EST
I had a similar problem with Dell D620 - no sound and mic didn't worked when used a headset. 
Applied kernel kernel-2.6.28.1-17.fc10 from koji and headset worked again (sound back).
But the sound was crackling, so the line was very bad when for you example used voip (internet call). It's was better that the line didn't work at all than crackling badly.

Found a simple solution for this crackling issue. Added a line
options snd-hda-intel model=dell-d22
to /etc/modprobe.conf and now the sound in line is clear/audible, no crackling anymore.

Tried also with model=dell-m22, see
http://www.mjmwired.net/kernel/Documentation/sound/alsa/ALSA-Configuration.txt
but it didn't helped.
Comment 34 Roland Roberts 2009-01-22 09:06:14 EST
I have the same problem with a Dell Latitude D820.  I upgraded from Fedora 8 to 9 then to 10 with no time spent at 9.  I can confirm that the last kernel from Fedora 8 worked perfectly.

I normally dock my D820 when at home.  When in the dock, the external speakers (plugged into the dock) do not work.  With kernels kernel-2.6.27.5-117.fc10.i686 and kernel-2.6.28-3.fc10.i686, the headphone jack on the laptop works normally, as do the laptop speakers.  With kernel-2.6.27.9-159.fc10.i686, only the laptop speakers work normally.

Under Fedora 8, I was able to toggle the microphone jack to operate as a line-in jack.  I'm a little vague on how I did this now, as it has been a while, but I remember it being via alsamixer and I cannot find the place to set this now.  It may have been via system-sound-config which is no longer part of Fedora 10....

When using audacity to capture sound, I do not seem to have any control over the input sound device.  Only the laptop's built-in microphone is used.  Only two input sources are displayed in audacity: "Capture: 0" and "Mux: 0".  Both appear to use the built-in microphone.  Anything plugged into the microphone jack is ignored as is my USB microphone.
Comment 35 Agustin Barto 2009-01-24 17:07:02 EST
Fixed on 2.6.27.12-170.2.5.
Comment 36 Ravindra Singh 2009-01-24 22:27:20 EST
great.... so when does this go upstream???
Comment 37 Matt McCutchen 2009-01-25 12:15:29 EST
The fixed kernel is currently in the updates-testing repo.  The update page:

https://admin.fedoraproject.org/updates/F10/FEDORA-2009-0923
Comment 38 Roland Roberts 2009-01-26 09:47:27 EST
This fixes both the headphone jack and the external speakers for my Dell Latitude D820.

However, the microphone/input jack problem is not solved.  Only the built-in microphone is accessible from audacity.  Line-in in not shown as a possible option for recording  (I use this, or did, all the time).  The built-in microphone is used, but my USB microphone *does* show up now (it did not before).
Comment 39 Leonid Kanter 2009-01-26 10:58:02 EST
Will there be the same fox for Fedora 9?
Comment 40 Chuck Ebbert 2009-01-29 00:35:13 EST
Commenters reporting unrelated bugs like non-working input selectors should file new bug reports.

Note You need to log in before you can comment on or make changes to this bug.