This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 477892 - SELinux denies 'read write' to restorecon on /root.
SELinux denies 'read write' to restorecon on /root.
Status: CLOSED DUPLICATE of bug 477508
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-24 19:27 EST by nol888
Modified: 2009-01-09 15:09 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 15:09:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nol888 2008-12-24 19:27:05 EST
Description of problem:
Attempting to `restorecon -R -v /root` results in a SELinux denial.  Summary "SELinux is preventing restorecon (setfiles_t) "read write" unconfined_t."

Version-Release number of selected component (if applicable):
3.5.13-18.fc10

How reproducible:
Always

Steps to Reproduce:
1. Attempt `restorecon' on /root.
  
Additional info:
Received this error after attempting to fix plethora of AVC denials as KDE started up as root.  Running restorecon only works on a few files before this AVC denial is thrown and restorecon fails with 'Operation not supported'.
Comment 1 Daniel Walsh 2008-12-27 07:04:02 EST
I think restorecon is completing and most of these avc's can be ignored.  kdebase is leaking file descriptors which SELinux is complaining about.  This has been reported in several other kdebase bugs.  The "Operation not supported"  is caused by you trying to run restorecon on a file system that does not support extended attributes.
Comment 2 Steven M. Parrish 2009-01-09 15:09:37 EST

*** This bug has been marked as a duplicate of bug 477508 ***

Note You need to log in before you can comment on or make changes to this bug.