Bug 477916 - Dec 25 13:27:28 surfplank2 NetworkManager: <WARN> nm_system_replace_default_ip4_route(): replace_default_ip4_route() returned error Unknown error 18446744073709551515 (-101)
Dec 25 13:27:28 surfplank2 NetworkManager: <WARN> nm_system_replace_default_...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-25 07:42 EST by udo
Modified: 2009-03-08 15:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.7.0.99-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 15:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2008-12-25 07:42:02 EST
Description of problem:
Default ipv4 gateway not set correctly, error in messages file:  NetworkManager: <WARN>  nm_system_replace_default_ip4_route(): replace_default_ip4_route() returned error Unknown error 18446744073709551515 (-101)
 

Version-Release number of selected component (if applicable):
0.7.0-0.12.svn4326.fc10

How reproducible:
Configure machine, boot machine and watch network interfaces brought up. do netstat -r to see routing

Steps to Reproduce:
1. Configure
2. boot
3. netstat -r
  
Actual results:
no or wrong(!) default gateway

Expected results:
Correctly set up networking

Additional info:
Fedora 10, x86_64 box with eth0 and usb0 interfaces.
eth0 connects to the LAN which  has firewall and ADSL.
usb0 connects to the iPAQ.
Box does forwarding and masquerading so iPAQ can get to the internet to get updates etc.
Default GATEWAY=192.168.10.98 for all interfaces
When configuring with System -> Administration -> Network or Network Device Control it is unclear which is THE default gateway for IP networking.
Things come up with wrong routes, errors appear in /var/log/messages

Dec 25 13:23:15 surfplank2 NetworkManager: <info>  Activation (usb0) Stage 4 of 5 (IP Configure Get) complete.
Dec 25 13:23:15 surfplank2 NetworkManager: <info>  Activation (usb0) Stage 5 of 5 (IP Configure Commit) started...
Dec 25 13:23:15 surfplank2 avahi-daemon[2773]: Joining mDNS multicast group on interface usb0.IPv4 with address 192.168.0.200.
Dec 25 13:23:15 surfplank2 avahi-daemon[2773]: New relevant interface usb0.IPv4 for mDNS.
Dec 25 13:23:15 surfplank2 avahi-daemon[2773]: Registering new address record for 192.168.0.200 on usb0.IPv4.
Dec 25 13:23:16 surfplank2 NetworkManager: <info>  Policy set 'System usb0' (eth0) as default for routing and DNS.
Dec 25 13:23:16 surfplank2 NetworkManager: <info>  (usb0): device state change: 7 -> 8
Dec 25 13:23:16 surfplank2 NetworkManager: <WARN>  nm_system_replace_default_ip4_route(): replace_default_ip4_route() returned error Unknown er
ror 18446744073709551515 (-101)
Dec 25 13:23:16 surfplank2 NetworkManager: <info>  Policy set 'System usb0' (usb0) as default for routing and DNS.
Dec 25 13:23:16 surfplank2 NetworkManager: <info>  Activation (usb0) successful, device activated.
Dec 25 13:23:16 surfplank2 NetworkManager: <info>  Activation (usb0) Stage 5 of 5 (IP Configure Commit) complete.
Dec 25 13:23:16 surfplank2 avahi-daemon[2773]: Registering new address record for fe80::8020:e9ff:fe56:4b3f on usb0.*.
Dec 25 13:23:17 surfplank2 ntpd[2533]: Listening on interface #23 usb0, fe80::8020:e9ff:fe56:4b3f#123 Enabled
Dec 25 13:23:17 surfplank2 ntpd[2533]: Listening on interface #24 eth0, 192.168.10.70#123 Enabled
Comment 1 udo 2008-12-25 07:43:26 EST
Because routing is wrong we have no network which is very bad; therefore the priority/severity should be high.

First we can verify my configuration so we can understand we have a problem.
Comment 2 udo 2009-01-18 05:28:26 EST
Also see https://bugzilla.redhat.com/show_bug.cgi?id=480525
That is a similar but different issue.
Comment 3 Dan Williams 2009-02-13 07:02:55 EST
Fixed some issues with error reporting upstream in f0b6da5fe8e217c90240a2c3ec1f40522ee98f27; we'll need that to figure out what the error actually is.  SHould show up in next fedora update.
Comment 4 Fedora Update System 2009-02-24 15:50:24 EST
NetworkManager-0.7.0.97-5.git20090220.fc10, NetworkManager-openconnect-0.7.0.97-1.fc10, NetworkManager-pptp-0.7.0.97-1.fc10, NetworkManager-openvpn-0.7.0.97-1.fc10, NetworkManager-vpnc-0.7.0.97-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openconnect NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1985
Comment 5 Fedora Update System 2009-02-27 22:24:51 EST
NetworkManager-0.7.0.98-1.git20090225.fc10, NetworkManager-openconnect-0.7.0.97-1.fc10, NetworkManager-pptp-0.7.0.97-1.fc10, NetworkManager-openvpn-0.7.0.97-1.fc10, NetworkManager-vpnc-0.7.0.97-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openconnect NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1985
Comment 6 Fedora Update System 2009-03-06 12:35:19 EST
NetworkManager-0.7.0.99-1.fc10,knetworkmanager-0.7-0.8.20080926svn.fc10,NetworkManager-vpnc-0.7.0.99-1.fc10,NetworkManager-openvpn-0.7.0.99-1.fc10,NetworkManager-pptp-0.7.0.99-1.fc10,NetworkManager-openconnect-0.7.0.99-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-1.fc10,knetworkmanager-0.7-0.8.20080926svn.fc10,NetworkManager-vpnc-0.7.0.99-1.fc10,NetworkManager-openvpn-0.7.0.99-1.fc10,NetworkManager-pptp-0.7.0.99-1.fc10,NetworkManager-openconnect-0.7.0.99-1.fc10
Comment 7 Fedora Update System 2009-03-06 12:52:05 EST
NetworkManager-0.7.0.99-1.fc9,NetworkManager-vpnc-0.7.0.99-1.fc9,NetworkManager-openvpn-0.7.0.99-1.fc9,NetworkManager-pptp-0.7.0.99-1.fc9,NetworkManager-openconnect-0.7.0.99-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-1.fc9,NetworkManager-vpnc-0.7.0.99-1.fc9,NetworkManager-openvpn-0.7.0.99-1.fc9,NetworkManager-pptp-0.7.0.99-1.fc9,NetworkManager-openconnect-0.7.0.99-1.fc9
Comment 8 Fedora Update System 2009-03-08 15:30:37 EDT
NetworkManager-0.7.0.99-1.fc9, NetworkManager-vpnc-0.7.0.99-1.fc9, NetworkManager-openvpn-0.7.0.99-1.fc9, NetworkManager-pptp-0.7.0.99-1.fc9, NetworkManager-openconnect-0.7.0.99-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-03-08 15:32:06 EDT
NetworkManager-0.7.0.99-1.fc10, knetworkmanager-0.7-0.8.20080926svn.fc10, NetworkManager-vpnc-0.7.0.99-1.fc10, NetworkManager-openvpn-0.7.0.99-1.fc10, NetworkManager-pptp-0.7.0.99-1.fc10, NetworkManager-openconnect-0.7.0.99-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.