Bug 477938 - Impossible to add a new sink using bluetooth headset
Impossible to add a new sink using bluetooth headset
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-12-25 17:51 EST by Luca Foppiano
Modified: 2009-04-03 13:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-03 12:18:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Luca Foppiano 2008-12-25 17:51:38 EST
Description of problem:
I'm trying to make my bluetooth headsets working, and I'm using this guide:


when I use this command:

pactl load-module module-alsa-sink device=bluetooth

I got this error:

Failure: Module initalization failed

in /var/log/messages I get:

Dec 25 23:43:50 localhost pulseaudio[2773]: alsa-util.c: Failed to set hardware parameters on plug:bluetooth: Invalid argument
Dec 25 23:43:50 localhost pulseaudio[2773]: module.c: Failed to load  module "module-alsa-sink" (argument: "device=bluetooth"): initialization failed.

Version-Release number of selected component (if applicable):

How reproducible:
Just following this guide: http://wiki.bluez.org/wiki/HOWTO/AudioDevices#Tryingpulse

Additional info:

I tried using directly alsa and my headset worked; after adding this configuration


to my .asoundrc, I tried with mplayer, 


and it worked.
Comment 1 Lennart Poettering 2009-04-03 12:18:47 EDT
Please use the native BT support in PA now which is available in Rawhide and will be part of F11. Going via ALSA is very problematic.
Comment 2 Luca Foppiano 2009-04-03 13:37:36 EDT

Note You need to log in before you can comment on or make changes to this bug.