Bug 477941 - doesn't respect trough-side-details
doesn't respect trough-side-details
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk-nodoka-engine (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-25 22:01 EST by Matthias Clasen
Modified: 2009-08-15 04:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.7.2-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-31 12:46:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Solution 1 (12.21 KB, patch)
2008-12-26 18:01 EST, Martin Sourada
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2008-12-25 22:01:54 EST
I was looking at turning off the filled in appearance of the lower half of the trough in scales for the 'fade' control in the new volume applet, since it is not appropriate there. 

GTK+ has a GtkRange::trough-side-details style property that is supposed to control the ability of theme engines to differentiate between lower and upper half of the trough by passing in different details. 

Clearlooks uses this mechanism, and consequently it is possible to turn off the filled in appearance by overriding the style property in the application. 

Nodoka on the other hand, finds the adjustment value, and bases its fill drawing on that. Manually poking at the innards of the widget like that from a theme engine is bad. Nodoka should respect the trough-side-details style property and 
base its fill drawing on the detail string: trough-lower vs trough-upper.
Comment 1 Martin Sourada 2008-12-26 05:53:44 EST
Thanks for the catch. I'll look at it later today or tomorrow (hopefully).
Comment 2 Martin Sourada 2008-12-26 18:01:49 EST
Created attachment 327869 [details]
Proposed Solution 1

I've just finished first approach on this matter. Can you try if it works with this patch as expected?
Comment 3 Martin Sourada 2008-12-30 12:04:47 EST
Package with this patch applied has just finished building for rawhide. I think it behaves now as expected, but would like you to check it as well before closing the bug. Thanks.

http://koji.fedoraproject.org/koji/buildinfo?buildID=76747
Comment 4 Matthias Clasen 2008-12-30 15:42:53 EST
I will test it when I'm back in rawhide, thanks.
Comment 5 Matthias Clasen 2008-12-31 11:44:26 EST
Works fine, thanks.
Comment 6 Fedora Update System 2009-07-24 08:20:42 EDT
gtk-nodoka-engine-0.7.2-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gtk-nodoka-engine-0.7.2-5.fc10
Comment 7 Fedora Update System 2009-08-15 04:07:37 EDT
gtk-nodoka-engine-0.7.2-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.