Bug 477943 - gnome-power-manager does not correctly display the charge or capacity of a laptop battery
gnome-power-manager does not correctly display the charge or capacity of a la...
Status: CLOSED DUPLICATE of bug 479322
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-25 22:40 EST by Robert Thomas
Modified: 2009-01-29 03:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 03:10:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Thomas 2008-12-25 22:40:55 EST
Description of problem:  g-p-m does not correctly calculate the remaining charge of a laptop battery, or does not correctly calculate the capacity of the battery.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.25.1-2.fc11.i386

How reproducible:
Always.

Additional info:
g-p-m is giving the following problems:
1) I receive warnings saying that my battery has a capacity of 0% and is either old or broken. Yet it is not, since it was only since the last update to 2.25 that I have received this error (and I have since run for over an hour without AC power);

2) The g-p-m icon reports "Laptop Battery Fully Charged (nan%)", or, when running off battery power, "Laptop Battery Discharging (nan%)". There is no indication of how much charge is truly left in the battery (I'm guessing this percentage calculation must have a division by zero error?);

3) I no longer have a "Hibernate" option in my shutdown box;

4) It no longer responds when I unplug the power cord. I need to restart the computer for it to realise that it is now running on battery power.
Comment 1 Robert Thomas 2009-01-16 19:27:12 EST
Issues (1), (2) and (4) still exist in gnome-power-manager-2.25.2-1.fc11.i386.
Comment 2 Robert Thomas 2009-01-29 03:10:15 EST

*** This bug has been marked as a duplicate of bug 479322 ***

Note You need to log in before you can comment on or make changes to this bug.