Bug 477950 - /usr/share/openbox/xdg-menu fails due to missing gmenu module
/usr/share/openbox/xdg-menu fails due to missing gmenu module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-26 04:03 EST by Joonas Sarajärvi
Modified: 2009-07-24 06:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 06:40:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joonas Sarajärvi 2008-12-26 04:03:45 EST
Description of problem:

The default openbox installation lacks automatically generated menus due to a missing gmenu Python module. This module is available in the gnome-menus package, whose installation fixes the problem.

I'm not sure if openbox really should depend on gnome-menus, but maybe some more graceful way to work around the missing Python module would be good to have. Maybe even only a note of this behaviour in /usr/share/doc/openbox-* would be enough.

Version-Release number of selected component (if applicable):
openbox-3.4.7.2-7.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1.Install openbox
2.Remove gnome-menus
3.Log in with a user without existing openbox configuration 
  
Actual results:
Openbox has only empty menus in the default root menu.

Expected results:
Some sane default menus, like the autogenerated menus which appear after installation of the gnome-menus package.

Additional info:
Comment 1 Miroslav Lichvar 2009-07-24 06:40:40 EDT
openbox-3.4.7.2-9.fc12 now depends on gnome-menus.

Note You need to log in before you can comment on or make changes to this bug.