Bug 477960 - Torque apparently doesn't install pbs-config
Torque apparently doesn't install pbs-config
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: torque (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Garrick Staples
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-26 08:57 EST by bob mckay
Modified: 2008-12-26 22:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-26 10:19:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2008-12-26 08:57:11 EST
Description of problem:
Installation of torque seems to omit the file pbs-config, which is required for upgrading the deprecated built-in scheduler to Maui. 

Version-Release number of selected component (if applicable):
2.1.10

How reproducible:
Completely

Steps to Reproduce:
1. Install Torque
2. Download Maui from http://www.clusterresources.com
3. ./configure
  
Actual results:
configure: WARNING: Resource Manager not specified - attempting build with pbs
configure: error: can't find pbs-config or libpbs.a

A complete 'find' on the whole system fails to reveal a copy of pbs-config


Expected results:
Maui installs


Additional info:
I realise this is an inquiry about a component (Maui) that isn't directly supported by fedora project. However:
.I suspect that it would not be difficult to include pbs-config in the distribution
.the documentation of the component which is installed (i.e. torque pbs-server and pbs-sched) itself recommends installing Maui for all but the most trivial scheduling requirements.
Comment 1 Garrick Staples 2008-12-26 10:19:12 EST
'yum install libtorque-devel' to get pbs-config and the other required development files.
Comment 2 bob mckay 2008-12-26 22:19:33 EST
(In reply to comment #1)
> 'yum install libtorque-devel' to get pbs-config and the other required
> development files.

Oooops, my bad. Thanks for the help Garrick.

Still, it probably won't hurt to have this bug report here, to assist others who hit the same problem. Since torque, except for the fedora setup, is generally installed from sources, the documentation for installing Maui and other extensions generally just assumes the sources are available. Actually, I might put a note in fedoraforum about this, since that's probably the first place people look.
    All the Best for New Year
    Bob

Note You need to log in before you can comment on or make changes to this bug.