This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 477975 - gnome-terminal freezing after "exit" command or clicking the exit button
gnome-terminal freezing after "exit" command or clicking the exit button
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-26 15:10 EST by Deb Mukherjee
Modified: 2009-08-09 15:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-09 15:59:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
flash video of the problem (3.78 MB, application/x-shockwave-flash)
2009-03-08 20:51 EDT, Deb Mukherjee
no flags Details

  None (edit)
Description Deb Mukherjee 2008-12-26 15:10:29 EST
Description of problem:
gnome-terminal is functioning properly until exit command is given or exit button is clicked- after which killing the process is the only way forward. 

Version-Release number of selected component (if applicable):


How reproducible:
Open gnome-terminal in fedora 10 and issue "exit" command or press the exit button. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The gnome-terminal does not terminate. 

Expected results:
the terminal window closes and the process terminates.

Additional info:
Comment 1 Deb Mukherjee 2009-01-15 23:33:25 EST
After installing today's gone-terminal update the problem still persists.
Comment 2 Deb Mukherjee 2009-03-08 20:51:07 EDT
Created attachment 334454 [details]
flash video of the problem

Please have a look at the problem.
can anyone please tell me how to get a stack trace of gnome-terminal? I have down loaded the gnome-terminal-debuginfo from fedora-debuginfo- but not going much further with bug-buddy when the crash is happening.
Comment 3 Thomas Spura 2009-08-08 18:59:32 EDT
This seems to be a Fedora 10 problem.
With Fedora 11 it works as expected and the latest update for F10 was on  	2009-01-15 22:32:13.

I tried to run 'gdm gnome-terminal' but you won't get that easily stacktraces...

But you could try 'gdm gnome-terminal -e "exit"'. It will directly run exit after it started. Not sure if it'll work, but give it a try ;-)
Comment 4 Deb Mukherjee 2009-08-09 15:59:44 EDT
Thanks for all the replies.

I believe this bug was specific to my system, as it was not reproducible by majority of fedora 10 users. Since then I have moved to F11 and have no issues.
Thus I am closing the thread.

Note You need to log in before you can comment on or make changes to this bug.