Bug 47817 - mplayer complains about gcc-2.96 (MMX involved)
mplayer complains about gcc-2.96 (MMX involved)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
http://192.190.173.45/homepage/faq.html
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-07 18:12 EDT by martin.macok
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-07 18:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description martin.macok 2001-07-07 18:12:04 EDT
I was compiling new MPlayer-0.18pre and it complains about gcc version.
So I read the DOCS and found this in their FAQ:

Q: What's the problem with gcc 2.96 ?
A: gcc 2.96 is RedHat's UNOFFICIAL (it can be found only on RedHat sites,
or RedHat distributions) and BUGGY gcc release. gcc 2.96 is TOTALLY
unsupported by MPlayer, because it simply SKIPS MMX codes, it just does not
compile it. Important: this is NOT an MPlayer-specific problem, numerous
other projects (DRI, avifile, etc..) have problems with this shit too.
** DO NOT USE gcc 2.96 !!! **

When I ./configure --disable-gcc-checking it compiles and run well.
gcc-2.96-85
kernel-2.4.3-12
CPU: AMD Athlon 850

If they're true (and I cannot find it in rh's bugzilla) someone should fix
it. If they're not - someone should tell them to not blame rh's gcc.

This is their development mailing list:
http://lists.sourceforge.net/lists/listinfo/mplayer-dev-eng
Comment 1 Jakub Jelinek 2001-07-20 06:23:31 EDT
I don't know what they are talking about.
I remember something about using | in comments in inline MMX assembly
but am not sure if it was MPlayer or what.
| cannot be used in IA-32 inline assembly with gcc-2.96-RH+ (including 3.0),
since it unlike 2.95 supports more than one assembly standard (AT&T and Intel).
We don't consider gcc-2.96-RH "totally buggy" and are working on fixing bugs
which get reported to us.

Note You need to log in before you can comment on or make changes to this bug.