Bug 47823 - heisenbug involving will/won't run for one user: rest seem fine.
heisenbug involving will/won't run for one user: rest seem fine.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-07 19:20 EDT by Telsa Gwynne
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-08 15:42:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script of moz working for all users except one (1.02 KB, text/plain)
2001-07-07 19:27 EDT, Telsa Gwynne
no flags Details

  None (edit)
Description Telsa Gwynne 2001-07-07 19:20:42 EDT
I don't know how I have achieved this.

I can no now longer recall whether I originally ran mozilla successfully
as a plain user, 'hobbit'. I believe I did. Subsequently I experimented
with nautilus as this user and it wouldn't start the help browser, which
I believe is a mozilla?

So I tried to run it from the command line. It wouldn't. It segfaulted
repeatedly on attempts to run it. The backtrace is all "in ?? ()" so I
have spared you that. It would run for root when I su'd to it, and it
would run for a test user.

I was going to speculate that perhaps when I changed the preferences
for the hobbit user I had found a bug, but I just attempted to verity
that it still wouldn't run for hobbit and now it will.

All of this was in the same X session, using su user and ssh -l user to
change users.

I'm sorry this is so nebulous. What more info do you need? The only other
potential clue is that rpm -V mozilla complains:
[hobbit@pwca hobbit]$ rpm -V mozilla
S.5....T   /usr/lib/mozilla/component.reg
S.5....T   /usr/lib/mozilla/components/xpti.dat
S.5....T   /usr/lib/mozilla/components/xptitemp.dat
but I don't know whether this is relevant.
Comment 1 Telsa Gwynne 2001-07-07 19:27:07 EDT
Created attachment 22967 [details]
script of moz working for all users except one
Comment 2 Christopher Blizzard 2001-07-08 12:40:41 EDT
Well, that's just scary.  Is that version 0.9.1 like the other bug reports I've
just gotten from you two? :)

There was a problem with 0.9.1 that was fixed just before 0.9.2 was released
related to profiles and starting up.  This might be it.  Can you try that
version of the rpm and get back to me?
Comment 3 Telsa Gwynne 2001-07-08 14:46:57 EDT
Sure. Um. Where from? :)
Comment 4 Christopher Blizzard 2001-07-08 15:42:31 EDT
Normally I'd saw rawhide but it looks like rawhide hasn't been updated with
newer packages.  Alan should be able to get it from the internal red hat trees.
 If not you can get it from here:

http://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.2/Red_Hat_7x_RPMS/i386/

The differences between that and the Red Hat rpms are mostly cosmetic so you
should be able to use it to test this problem.
Comment 5 Christopher Blizzard 2001-08-15 16:15:11 EDT
<telsa> It hasn't happned again, so I presume fixed.

Do we have a Works For Telsa resolution?

Note You need to log in before you can comment on or make changes to this bug.