Bug 478310 - Fedora 10 upgrade crashes
Fedora 10 upgrade crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-27 15:05 EST by Joseph Perrin
Modified: 2014-01-21 18:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 11:37:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump (112.05 KB, text/plain)
2008-12-27 15:05 EST, Joseph Perrin
no flags Details

  None (edit)
Description Joseph Perrin 2008-12-27 15:05:19 EST
Created attachment 327888 [details]
Anaconda Dump

Description of problem:
Upgrading from FC9 to 10.  I'm in the midst of installing ~500 of 1050 packages, when the screen saver appears to kick in.  (Which I think is completely stupid!)  I shake the mouse and it's clear video memory has been clobbered.  (vertical lines of random video artifacts, with a watch cursor that doesn't move.)  I can't change VCs, nothing works.  No disk activity.  After a *very* reasonable time, I have no choice but to reboot.  

I re-attempt the Upgrade, but now it crashes with an exception.  System still boots FC9, but things are broken.

Iso hash is good, DVD media is good.  Installer apparently doesn't tolerate the ambiguity???


Version-Release number of selected component (if applicable):


How reproducible:
Each time I try to Upgrade.

Steps to Reproduce:
1. Boot w/ FC10 DVD
2. ...Choose Upgrade existing FC9 partition.
3. Bootloader set to default.
4. First graph goes to 100%
5. Installing System gets ~33% then goes to 100%, and dies!
  
Actual results:
A fubared system.

Expected results:
Sadly, not much more than this!  


Additional info:
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 15
model		: 2
model name	: Intel(R) Pentium(R) 4 CPU 2.40GHz
stepping	: 9
cpu MHz		: 2393.994
cache size	: 512 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up pebs bts cid xtpr
bogomips	: 4787.98
clflush size	: 64
power management:
Comment 1 Joseph Perrin 2009-01-05 13:29:34 EST
I found a solution...  Ok, I actually *read* the dump!  [gasp!]  A corrupt rpm was left in /mnt/sysimage/var/cache/yum/anaconda-InstallationRepo-200811191949.i386/packages/ at the time of the crash, which contained zero bytes.

Seems to me, RPMs in that lib need to bet clobbered upon upgrade??  Or is there some purpose in possibly having RPMs already in there, (i.e. to Override distro contents perhaps?)  

Anyway, that fixed it for me, and all is fine now.
Comment 2 Michael Price 2009-03-03 13:08:46 EST
This bug has been triaged
Comment 3 seth vidal 2009-03-03 15:39:23 EST
over to anaconda from yum.
Comment 4 Chris Lumens 2009-06-10 15:47:01 EDT
I believe this should be fixed due to the fix for 501887.  If you are still experiencing this problem with post-F11 rawhide, feel free to reopen this bug and let us know.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.