Bug 478328 - gutenprint-5.2.3-1 does not print on Epson CX3810
gutenprint-5.2.3-1 does not print on Epson CX3810
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gutenprint (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 03:34 EST by Jayson King
Modified: 2009-01-21 16:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 16:26:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jayson King 2008-12-28 03:34:24 EST
Description of problem:
gutenprint-5.2.3-1 and gutenprint-foomatic-5.2.3-1 from updates-testing causes prints to die on my Epson CX3810. Downgrading to 5.0.2-3 allows printing to work again.

Version-Release number of selected component (if applicable):
5.2.3-1

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Nothing related appears in cups error_log. Please suggest some debugging I can turn on to try to catch something.
Comment 1 Tim Waugh 2008-12-28 14:11:32 EST
Please try using the printing troubleshooter: System->Administration->Printing, then Help->Troubleshoot.  It might be able to spot what's wrong, and if not it will give you a troubleshoot.txt file to attach to this bug report.

Let me know what it says.
Comment 2 Jayson King 2008-12-28 23:00:07 EST
It reported that the driver was missing, and in fact the driver provided for my printer was renamed from "Epson Stylus CX3810 Foomatic/gutenprint-ijs-simplified.5.0" to "Epson Stylus CX3810 Foomatic/gutenprint-ijs-simplified.5.2".

Changing the driver to the correct name allows the printer to work again.

I don't suppose there's a way for the rpm installer to correct for the name change in the driver automatically, is there?
Comment 3 Paul Jenner 2008-12-29 11:30:51 EST
I saw what sounds like the same issue with Epson Stylus CX6400 and upgrade to Gutenprint 5.2.x from updates-testing.

In system-config-printer, Make and Model included text "Foomatic/gutenprint-ijs-simplified.5.0". Printing failed.

Using system-config-printer Make and Model "Change" button and subsequent dialogues to select the same printer, Make and Model changed to "Epson Stylus CX6400 Foomatic/gutenprint-ijs-simplified.5.2" and printing worked again.

yum upgrade of the gutenprint* packages reported:

ERROR: foomatic-ppdfile: Printer 'Epson-Stylus_CX6400' and driver 'gutenprint-ijs-simplified.5.0' are not compatible
ERROR: foomatic-ppdfile: Driver 'gutenprint-ijs-simplified.5.0' not in database!

I assume this was from:

[root@localhost cups]# rpm -q --scripts gutenprint-foomatic
postinstall scriptlet (using /bin/sh):
/bin/rm -f /var/cache/foomatic/*
/usr/sbin/gutenprint-foomaticppdupdate 5.2.3 || :

Apologies for the vagueness - I should have captured a lot better debug information.
Comment 4 Tim Waugh 2009-01-08 11:35:56 EST
Should be fixed in the next build.  The gutenprint-foomaticppdupdate script was not changing the driver name to (e.g.) gutenprint-ijs-simplified.5.2.
Comment 5 Paul Jenner 2009-01-08 15:53:09 EST
What is best method to test and confirm fix?

Downgrade to (stable updates) gutenprint-* 5.0, remove and re-add printer to get back to 5.0 driver and then test package upgrade again?
Comment 6 Tim Waugh 2009-01-08 17:57:22 EST
I think that's best, yes.
Comment 7 Fedora Update System 2009-01-14 22:07:55 EST
gutenprint-5.2.3-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gutenprint'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10872
Comment 8 Jayson King 2009-01-15 19:11:20 EST
I upgraded from 5.0 -> 5.2.3-3 again (per comment #5) and it appears to work now, changing the driver name to 5.2 as it should. Thanks.
Comment 9 Paul Jenner 2009-01-19 16:28:07 EST
Upgraded successfully from gutenprint-foomatic-5.0.2-3.fc10 to gutenprint-foomatic-5.2.3-3.fc10. PPD file successfully upgraded (no errors) and printing worked fine after the upgrade.

Minor issue - properties for the printer in system-config-printer after the upgrade is still showing Make and Model as "Foomatic/gutenprint-ijs-simplified.5.0" but printing works.
Comment 10 Tim Waugh 2009-01-19 16:48:46 EST
Maybe restart CUPS?  I'd really like to avoid doing that automatically because it will restart any long-running jobs.
Comment 11 Tim Waugh 2009-01-20 05:06:15 EST
I've adjusted the update so that it suggests a reboot, to take care of that problem.
Comment 12 Fedora Update System 2009-01-21 16:26:14 EST
gutenprint-5.2.3-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.