Bug 478349 - Problem with NetworkManager managing two wireless adapters and wireless kill switch
Problem with NetworkManager managing two wireless adapters and wireless kill ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 11:16 EST by Jaroslav Franek
Modified: 2009-02-12 19:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 19:23:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Franek 2008-12-28 11:16:53 EST
Description of problem:

The configuration is this: HP nx7000 notebook with integrated Intel 2100 adapter (802.11b) and external USB wireles adapter Linksys WUSB300N (802.11b,g,n). Both devices handled by NetworkManager. However there is a catch: The hardware wireless kill switch set off tells the NetworkManager that both adapters are disabled. This is not true. The USB can be brought to life by
executing the following commands under root
# service NetworkManager stop
# service wpa_supplicant restart
# dhclient -v wlan0

When the NetworkManager service is running and the wireless kill switch make the wireless active, both interfaces do connect to the same network and get different IPs. I know this can be corrected by configuration (setting MAC address of the device) but it will make things a little bit complicated at user side as sometimes I connect via i2100, sometimes with WUSB300N (when available).

And anyway, to connect via WUSB300N I do not need integrated i2100 active to drain power from the notebook.

As a naive user I would expect that hardware wireless kill switch on the notebook only operates on the integrated wifi card, not the external one. In fact the external one is not affected at all, just the NetworkManager thinks so. And that is the problem I ask to fix.


Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.12.svn4326.fc10.i386
kernel-2.6.27.9-159.fc10.i686

How reproducible:
see above

Steps to Reproduce:
1. connect external USB wifi card (Linksys WUSB300N), firmware installed, ndiswraper installed, configured
2. boot the computer with wireless kill switch off

  
Actual results:

No connection is made.
Network manager menu says:

Wireless Network (Intel Samsung X10/P30 integrated WLAN)
wireless is disabled
Wireless Network (Linksys Wireless-N USB Network Adapter v1021)
wireless is disabled


Expected results:

Connection to a wireless network is made via WUSB300N

Additional info:

Few weeks ago in Fedora 9, it has worked (i.e. WUSB300N got connected) for a short time. But around the time of the infamous d-bus downgrade it got broken again.
Comment 1 Dan Williams 2009-02-12 19:23:50 EST
Current policy is that the rfkill switch applies to *all* devices of that class.  Furthermore, there aren't good kernel-level mechanisms to distinguish which rfkill switches apply to which devices at this time, because there are no strong ties between the switch and the specific wifi device.  It's a combination of technical issues that can't be easily solved, and policy decisions to make things less complicated for everyone.  Unfortunately, this won't be fixed for a while.

Note You need to log in before you can comment on or make changes to this bug.