Bug 478351 - Fedora kernel updates killed sound on ICH10
Fedora kernel updates killed sound on ICH10
Status: CLOSED DUPLICATE of bug 477954
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 11:32 EST by Philip Imants Long
Modified: 2009-01-03 17:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-03 17:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Imants Long 2008-12-28 11:32:48 EST
Description of problem:

F10 kernel updates killed my ICH10 sound.


Version-Release number of selected component (if applicable):


How reproducible:

Install F10, notice good sound (if non-linear mixer volume) out of the box.

Update to kernel 2.6.27.7-134.fc10.i686.pae along with all the policykit stuff etc., notice that gstreamer sound still works but other stuff that used to does not, e.g. mplayer

Update to kernel 2.6.27.9-159.i686.pae and notice that there's no sound at all :(

Boot into 2.6.27.5-117 with all the other updates from grub and notice sound automagically restored to gstreamer and mplayer.

Actual results:

Broken sound

Expected results:

Working Sound

Additional info:

Intel G45 motherboard/sound card (DG45ID)

This is a bug I found which may have something to do with the problems, or maybe not.

https://bugzilla.redhat.com/show_bug.cgi?id=462200
Comment 1 Enrico Defranchi 2009-01-01 19:22:16 EST
I confirm this bug on a latitude D830 laptop running full-updated fedora 10.

Sound work with kernel 2.6.27.7-134.fc10.i686 (not using pae) and all previous fedora 10 kernel, not working in 2.6.27.9-159.i686 or 2.6.27.10-167.fc10.i686 .
Tried also   kernel-2.6.27.9-152.rc2.fc10.i686 : sound not working.

Using pulseaudio, and vumeter in pulseaudio indicate good treatment of music (from padevchooser applet) but no sound from loudspeaker, also trying to bypass pulseaudio and use alsa directly same behaviour.

Reading kernel changelog is possible the key element is new alsa:

* Mon Dec 08 2008 Chuck Ebbert <cebbert@redhat.com> 2.6.27.7-139
- ALSA 1.0.18a
  Dropped patches:
    linux-2.6-alsa-ac97-whitelist.patch
    linux-2.6-alsa-ac97-whitelist-AD1981B.patch
    linux-2.6-alsa-revo51-headphone.patch
    linux-2.6-olpc-speaker-out.patch

Maybe is possible to try 2.6.27.7-137 and 2.6.27.8-143 to see if sound changes accordingly.
Comment 2 Enrico Defranchi 2009-01-01 19:34:04 EST
Similar to Bug 475756
Comment 3 Enrico Defranchi 2009-01-02 11:17:39 EST
Ok, i tried diffrent kernels, soud worked until 2.6.27.7-137 and stop working with 2.6.27.8-143 , biggest candidate for stop working new alsa in my opinion.
Comment 4 Enrico Defranchi 2009-01-02 11:18:39 EST
[defraz@localhost ~]$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebfc000 irq 21
Comment 5 H.J. Lu 2009-01-03 17:35:28 EST
I also have ICH7. Sound doesn't work with kernel-2.6.27.9-159.fc10.x86_64
and 2.6.27.7-134.fc10.x86_64 is OK.
Comment 6 H.J. Lu 2009-01-03 17:43:23 EST

*** This bug has been marked as a duplicate of bug 477954 ***

Note You need to log in before you can comment on or make changes to this bug.