Bug 478357 - imlib-config --libs specifies more than enough libraries
imlib-config --libs specifies more than enough libraries
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: imlib (Show other bugs)
el5
All Linux
high Severity high
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 16:14 EST by Lubomir Rintel
Modified: 2009-06-20 09:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.9.15-11.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-20 09:09:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2008-12-28 16:14:29 EST
Description of problem:

imlib-config --libs specifies more than enough libraries. See "Additional info" for a specific case where this caused problems.

Version-Release number of selected component (if applicable):

imlib-1.9.15-6.el5

How reproducible:

Building with imlib on RHEL-5

Steps to Reproduce:

$ imlib-config --libs

Actual results:

-lImlib -ljpeg -ltiff -lgif -lpng -lm -lXext -lSM -lICE -lXext -lX11

Expected results:

Either just -lImlib, or these libraries Require:'d by imlib-devel

Additional info:

I hit the problem when I built the latest xteddy SRPM on RHEL-5. The imlib-config specifies -lSM, which I actually don't use and was not in my build root.

It would make sense to just not specify these, and let user decide which libraries to pick. But it may be that upstream an non-Linux users won't be much happy about that, in that case it may make sense to add all these as -devel package dependencies and add -Wl,--as-needed there so that the resulting binaries don't unnecessarily drag in the unused libraries.

Oh, and there's no need to update imlib in EPEL just for this.

Thanks!
Comment 1 Paul Howarth 2009-04-09 04:55:58 EDT
I'm going to add a dependency on libXt-devel to imlib-devel, which will ensure that all of the relevant libraries are present at link time.

I'm rather wary of adding -Wl,--as-needed though because it's an option that doesn't nest and so there's no way of restoring the existing state of the as-needed flag at the end of the imlib libraries list. I think it would be better to add this at the level of the application/library linking against imlib.

I'm also reluctant to make the more substantive change of just having -lImlib since this is really a legacy library and this change might break the existing users of the library, most of which are probably dead upstream (as indeed imlib is itself).
Comment 2 Paul Howarth 2009-04-22 04:53:45 EDT
imlib-1.9.15-11.el5 is now available in EPEL-5-testing:

http://download.fedora.redhat.com/pub/epel/testing/5/
Comment 3 Fedora Update System 2009-05-07 11:07:58 EDT
libglade-0.17-23.fc10,gnome-libs-1.4.2-14.fc10,imlib-1.9.15-11.fc10,ORBit-0.5.17-26.fc10,gtk+-1.2.10-68.fc10,glib-1.2.10-32.fc10,libxml-1.8.17-22.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libglade-0.17-23.fc10,gnome-libs-1.4.2-14.fc10,imlib-1.9.15-11.fc10,ORBit-0.5.17-26.fc10,gtk+-1.2.10-68.fc10,glib-1.2.10-32.fc10,libxml-1.8.17-22.fc10
Comment 4 Fedora Update System 2009-05-13 07:48:00 EDT
libglade-0.17-23.fc11,gnome-libs-1.4.2-14.fc11,imlib-1.9.15-11.fc11,ORBit-0.5.17-26.fc11,gtk+-1.2.10-68.fc11,glib-1.2.10-32.fc11,libxml-1.8.17-22.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libglade-0.17-23.fc11,gnome-libs-1.4.2-14.fc11,imlib-1.9.15-11.fc11,ORBit-0.5.17-26.fc11,gtk+-1.2.10-68.fc11,glib-1.2.10-32.fc11,libxml-1.8.17-22.fc11
Comment 5 Fedora Update System 2009-05-19 20:46:37 EDT
libglade-0.17-23.fc11, gnome-libs-1.4.2-14.fc11, imlib-1.9.15-11.fc11, ORBit-0.5.17-26.fc11, gtk+-1.2.10-68.fc11, glib-1.2.10-32.fc11, libxml-1.8.17-22.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-05-19 20:54:25 EDT
libglade-0.17-23.fc10, gnome-libs-1.4.2-14.fc10, imlib-1.9.15-11.fc10, ORBit-0.5.17-26.fc10, gtk+-1.2.10-68.fc10, glib-1.2.10-32.fc10, libxml-1.8.17-22.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Paul Howarth 2009-06-20 09:09:14 EDT
imlib-1.9.15-11.el5 is now available in EPEL-5:

http://download.fedora.redhat.com/pub/epel/5/

Note You need to log in before you can comment on or make changes to this bug.