Bug 478363 - Interface change suggestion for the Partitioning section of the Fedora installer.
Interface change suggestion for the Partitioning section of the Fedora instal...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AnacondaUI
  Show dependency treegraph
 
Reported: 2008-12-28 18:55 EST by Kyle Pointer
Modified: 2010-02-17 14:48 EST (History)
2 users (show)

See Also:
Fixed In Version: anaconda-13.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-17 14:48:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the screen I'm talking about. (2.10 MB, image/jpeg)
2008-12-28 18:55 EST, Kyle Pointer
no flags Details

  None (edit)
Description Kyle Pointer 2008-12-28 18:55:00 EST
Created attachment 327904 [details]
This is the screen I'm talking about.

Description of problem:

The partitioner in the installer makes it easy to accidentally add an unintended drive to an LVM, causing some data-loss issues. 


Version-Release number of selected component (if applicable):

As far as I know, the partitioner (used to be called disk-druid? still is?) has always done it this way.

Steps to Reproduce:
1. Have at least 4 hard drives.
2. Run installer.
3. Select "Remove Linux/All partitions and replace with default"
4. Do not notice that you missed a checkbox. [ because it is not visible, and you're used to seeing all of your drives because you've always had just 3 ] 
5. Continue installation normally.
6. Realize after about 30 minutes that you're missing 320Gb of data.
  
Actual results:

I was mad at myself for being stupid.

Expected results:

I didn't expect the installer to format an extra hard drive. 

Additional info:

I concede, this was 100% *my fault*, but I think it's worth changing non-the-less, because it could help prevent stupid users like me from accidentally losing data.

Suggested fix:

There's a few things I might suggest...

1. Make the hard drive selection widget bigger so it shows more of your drives without the scroll-bar.
This might help the issue of not noticing if you have an extra drive. There's at least a line or two worth of freespace between the "Review..." text and the "Back Next" buttons [ at least at higher resolutions... I've never seen the installer lower than 1280x1024 ]

2. Before actually writing anything perhaps a small pop-up dialogue that says "THESE DRIVES WILL BE FORMATTED IF YOU CONTINUE - [drive name], [size (preferably in gigabytes)],\newline etc..."

3. How about having the default state of the hard drives in the list be "do NOT format", so it's opt-in instead of opt-out? That way you check the drives you want to be formatted, and if there's another drive that simply isn't visible, it won't automagically be formatted and added to the LVM config.
Comment 1 Joel Andres Granados 2009-09-09 07:28:38 EDT
(In reply to comment #0)
> Created an attachment (id=327904) [details]
> This is the screen I'm talking about.
....
> Suggested fix:
> 
> There's a few things I might suggest...
> 
> 1. Make the hard drive selection widget bigger so it shows more of your drives
> without the scroll-bar.
> This might help the issue of not noticing if you have an extra drive. There's
> at least a line or two worth of freespace between the "Review..." text and the
> "Back Next" buttons [ at least at higher resolutions... I've never seen the
> installer lower than 1280x1024 ]
> 

This is not an option.  Making the widget bigger does not help in the general case.  It only helps the users that have one or two devices more than the widget can handle.  For users that have 3 or more drives you would get the same situation.

> 2. Before actually writing anything perhaps a small pop-up dialogue that says
> "THESE DRIVES WILL BE FORMATTED IF YOU CONTINUE - [drive name], [size
> (preferably in gigabytes)],\newline etc..."

This is already the behavior.  You can choose to review your options.

> 
> 3. How about having the default state of the hard drives in the list be "do NOT
> format", so it's opt-in instead of opt-out? That way you check the drives you
> want to be formatted, and if there's another drive that simply isn't visible,
> it won't automagically be formatted and added to the LVM config.  

This is actually something that might be useful for the filtering stuff that is being done for f13.

Clumens:
Use your better judgment to close or keep this bug.
Comment 2 Chris Lumens 2009-10-02 09:30:05 EDT
#3 is basically how the filtering stuff will work, yes.  You'll have to check the devices you even want included in the install, and then you will also have to check the devices you want formatted as opposed to just mounted.
Comment 3 Bug Zapper 2009-11-16 04:44:48 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Chris Lumens 2009-12-14 11:38:54 EST
#3 from above is now implemented in the filtering UI that I committed at the end of last week, and will be F13 alpha/beta/etc.

Note You need to log in before you can comment on or make changes to this bug.