Bug 478369 - Acer TravelMate C100 needs vbe_post quirk to wake from suspend
Acer TravelMate C100 needs vbe_post quirk to wake from suspend
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 20:39 EST by Richard Schwarting
Modified: 2009-09-17 07:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 07:42:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to quirk file for ACER TravelMate C100 (1.22 KB, patch)
2008-12-28 23:25 EST, Richard Schwarting
no flags Details | Diff

  None (edit)
Description Richard Schwarting 2008-12-28 20:39:33 EST
==Description of problem:

Acer TravelMate C100 won't resume from suspend properly without the following quirk: vbe_post.  Also, HAL doesn't seem to load this quirk from the corresponding HAL quirk file.

I can hibernate successfully.  When resuming from suspend to RAM, it will normally just go to a black screen which gradually washes over with stripes.  It is not directly X related, as the same issue occurs when I suspend from the terminal with pm-suspend.  Trying the various quirks listed Richard Hughes site for such, the following one allowed a proper resume from suspend:
$ pm-suspend --quirk-vbe-post

Enabling the hal property for this via:
$ hal-set-property --udi /org/freedesktop/Hal/devices/computer --key power_management.quirk.vbe_post --bool true
allows me to suspend properly from the GUI as well.

(NOTE: I couldn't get a change to the fdi file to be loaded by HAL, despite being seemingly correct; more in Additional Notes at bottom.)

I'm eagre to test any packages that are modified to support this quirk.  

==Version-Release number of selected component (if applicable):

hal-0.5.12-12.20081027git.fc10.i386

==How reproducible:

Always.

==Steps to Reproduce:
1. Suspend machine (without vbe_post quirk) (to RAM)
2. Resume from suspend

  
==Actual results:

You get a blank screen (with or without X) with the backlight on.  Gradually, mostly white and some colour starts bleeding across the screen in a line pattern.  

==Expected results:

The video is restored, like when you HAL has vbe_post property set (or if you used pm-suspend --quirk-vbe-post)

==Additional info:

I would submit a patch with the change made to the fdi file /usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-acer.fdi but HAL doesn't seem to load the quirk.  

This is the change I would have submitted.

--- 20-video-quirk-pm-acer.fdi	2008-12-28 17:28:21.000000000 -0800
+++ 20-video-quirk-pm-acer.fdi.orig	2008-12-28 17:25:52.000000000 -0800
@@ -24,9 +24,6 @@
         <match key="system.hardware.product" contains="6460">
           <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
         </match>
-        <match key="system.hardware.product" contains="C100">
-          <merge key="power_management.quirk.vbe_post" type="bool">true</merge>
-        </match>
         <match key="system.hardware.product" contains_outof="C200;2450;4400;6492">
           <merge key="power_management.quirk.none" type="bool">true</merge>

Though C100 and 6460 could be grouped with contains_outof, I suppose.  

I am fairly certain that that's a proper change to the file, given this output from lshal | grep hardware: 
  system.hardware.product = 'TravelMate C100'  (string)
  system.hardware.serial = '9148R013852390275DM000'  (string)
  system.hardware.uuid = 'B8133FC0-D30B-11D6-901F-9BBA3FEE1D4C'  (string)
  system.hardware.vendor = 'ACER'  (string)
  system.hardware.version = '-1'  (string)



I'll note that without the quirk, just running "vbetool post" from the command-line after a suspend does NOT restore the video.  Running it also causes my laptop to freeze at the next suspend.  However, the vbe_post HAL quirk works correctly.
Comment 1 Richard Schwarting 2008-12-28 23:25:25 EST
Created attachment 327905 [details]
Patch to quirk file for ACER TravelMate C100

This patch enables the Acer TravelMate C100 to resume from suspend, by setting it to use the vbe_post quirk.  Yay.
Comment 2 Scott Glaser 2009-09-09 08:31:29 EDT
Have you tried with the latest hal package in Fedora 10, Fedora 11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Richard Schwarting 2009-09-16 23:12:58 EDT
Sorry, that laptop of mine appears dead now.  I cannot get it to boot anymore to test.
Comment 4 Scott Glaser 2009-09-17 07:42:09 EDT
Based on the information provided in comment 3 I am going to close this bug, should you restore your laptop to working order and be able to replicate the symptoms observed in the bug, please file a new bug against the appropriate component.  Thank you for the time to report this issue.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.