Bug 478403 - Yum and python-2.6 have i18n problems in non-english locale
Yum and python-2.6 have i18n problems in non-english locale
Status: CLOSED DUPLICATE of bug 480514
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 477355 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 10:12 EST by hurricanek
Modified: 2014-01-21 18:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 11:31:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hurricanek 2008-12-29 10:12:44 EST
Description of problem:
If I use yum under the shell it will not display the entire message.
Does the translation is not complete?

Version-Release number of selected component (if applicable):
yum 3.2.20-8
python 2.6-1

How reproducible:
It happens every times. If I set LANG=zh_CN.UTF-8

Steps to Reproduce:
1.yum install package-name (update , any package exists is ok)
  
Actual results:
Loading mirror speeds from cached hostfile
 * fedora: opensource.nchc.org.tw
 * rpmfusion-free-updates: mirrors.tummy.com
 * rpmfusion-nonfree-updates: mirrors.tummy.com
 * rpmfusion-free: mirrors.tummy.com
 * rpmfusion-nonfree: mirrors.tummy.com
 * updates: opensource.nchc.org.tw
确定是这样吗? [y/N]:


Expected results:
Loaded plugins: allowdowngrade, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile                       
 * fedora: ftp.twaren.net                                        
 * rpmfusion-free-updates: mirrors.tummy.com                     
 * rpmfusion-nonfree-updates: mirrors.tummy.com                  
 * rpmfusion-free: mirrors.tummy.com                             
 * rpmfusion-nonfree: mirrors.tummy.com                          
 * updates: ftp.twaren.net                                       
Setting up Update Process                                        
Resolving Dependencies
--> Running transaction check
---> Package bash.i386 0:3.2-30.fc10 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================================================================
 Package                            Arch                               Version                                   Repository                             Size
=============================================================================================================================================================
Updating:
 bash                               i386                               3.2-30.fc10                               updates                               1.8 M

Transaction Summary
=============================================================================================================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 1.8 M
Is this ok [y/N]: N

Additional info:
Comment 1 seth vidal 2009-01-05 22:11:06 EST
Some of the problem could be python 2.6 at the moment, but it is true that not all of our translations are current.
Comment 2 hurricanek 2009-01-06 03:15:51 EST
But It's strange that yumex has all message shows. Yumex has it's own translation or it's just gain the raw message from yum? And Does it matter to use the previous translations? I think.
Comment 3 Tim Lauridsen 2009-01-06 04:58:26 EST
Yumex has it's own translations for most messages.
Comment 4 James Antill 2009-01-06 14:02:36 EST
What is this BZ about, if I do:

% LANG=zh_CN.UTF-8 sudo yum update python\*
载入插件: aliases, categories, changelog, conf, downloadonly, filter-data, keys,
        : list-data, noop, post-transaction-actions, security, tmprepo
Skipping filters plugin, no data
Skipping security plugin, no data
设置升级进程
解决依赖相关
Skipping filters plugin, no data
Skipping security plugin, no data
-->运行处理检查
---> 包 python-fedora.noarch 0:0.3.8-1.fc9 设置为 升级 
---> 包 python-setuptools.noarch 0:0.6c9-1.fc9 设置为 升级 
--> 完成依赖性检查

依赖性解决

================================================================================
 包                     架构        版本              仓库                 大小
================================================================================
正在升级:
 python-fedora          noarch      0.3.8-1.fc9       updates-newkey      113 k
 python-setuptools      noarch      0.6c9-1.fc9       updates-newkey      302 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)         

总共下载大小: 414 k
确定是这样吗? [y/N]: 
在用户的命令下退出
恭喜你!成功完成!

...is the problem the fact that some of the above is in english? Or do you get a drastically different output (lines from the above missing, and not in en or zh)?
Comment 5 James Antill 2009-01-06 14:06:30 EST
 btw. the above is with latest stable yum but python 2.5.x ... we are aware that python-2.6.x seems to be even more annoying about i18n output (and thus. removes lines, or blows up), so if you are saying that lines seem to be missing then it's probably not just you :).
Comment 6 hurricanek 2009-01-06 22:55:05 EST
As I was mentioned above, I use python-2.6 and yum 3.2.20, because I just want to try kde4.2-beta, so python updated to 2.6. And there was nothing wrong with yum in python 2.5 for me. For instance, with python-2.6 message below
"
-->运行处理检查
---> 包 python-fedora.noarch 0:0.3.8-1.fc9 设置为 升级 
---> 包 python-setuptools.noarch 0:0.6c9-1.fc9 设置为 升级 
--> 完成依赖性检查

依赖性解决

================================================================================
 包                     架构        版本              仓库                 大小
================================================================================
正在升级:
 python-fedora          noarch      0.3.8-1.fc9       updates-newkey      113 k
 python-setuptools      noarch      0.6c9-1.fc9       updates-newkey      302 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)      "

will be totally missing. So I have to use yum -v -d 5 to view what package to update.
Comment 7 James Antill 2009-01-07 00:51:52 EST
Ok, thanks, just making sure we understand where/what the problem is.
Comment 8 James Antill 2009-01-07 11:19:33 EST
*** Bug 477355 has been marked as a duplicate of this bug. ***
Comment 9 seth vidal 2009-01-21 11:31:39 EST

*** This bug has been marked as a duplicate of bug 480514 ***

Note You need to log in before you can comment on or make changes to this bug.