Bug 478405 - Incorrect license for Red Hat brand
Incorrect license for Red Hat brand
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 12:45 EST by Richard Fontana
Modified: 2014-08-25 20:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.40
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-15 20:22:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Fontana 2008-12-29 12:45:45 EST
Description of problem:

publican-redhat brand package legal notice assumes incorrect licensing for Red Hat documentation.  Additional restrictive "options" on the OPL are contrary to Red Hat documentation licensing policy.   

Further changes to Red Hat documentation licensing policy may entail further changes to such legal notices. However, at a minimum these additional restrictions on top of OPL are unacceptable. Therefore, the publican-redhat package should be modified accordingly. 

Version-Release number of selected component (if applicable):
 

How reproducible:
Happens every time

Steps to Reproduce:
1. Generate using Legal_Notice.xml
  
Actual results:

Copyright © 2008. This material may only be distributed subject to the terms and conditions set forth in the Open Publication License, V1.0 or later with the restrictions noted below (the latest version of the OPL is presently available at http://www.opencontent.org/openpub/).

Distribution of substantively modified versions of this document is prohibited without the explicit permission of the copyright holder.

Distribution of the work or derivative of the work in any standard (paper) book form for commercial purposes is prohibited unless prior permission is obtained from the copyright holder.

Expected results:

Copyright © 2008. This material may only be distributed subject to the terms and conditions set forth in the Open Publication License, V1.0 or later (the latest version of the OPL is presently available at http://www.opencontent.org/openpub/).
 
Additional info:

Content of default legal notices used in generating Red Hat-copyrighted material must in all cases be cleared with Red Hat Legal Affairs.
Comment 1 Karsten Wade 2008-12-30 00:14:57 EST
Removing publican-list@redhat.com, an open and public archive list that is automatically Cc:'d on all Publican bugs.  This list, being @redhat.com, is allowed by Bugzilla to receive bugs marked private for Red Hat.
Comment 2 Jeff Fearn 2009-01-04 17:47:54 EST
Yo Mike, I thought we put this issue to bed the last 8 thousand times it was raised.

I will not be changing this license without direct confirmation from Mike Hideo as he is the responsible party for this content.
Comment 3 Michael Hideo 2009-01-04 19:32:24 EST
Jeff,

Confirm you are clear to change the brand package. Re-publishing the content will need to be done into the Alexandria framework.


Richard,

There are 232,727 html and 942 pdf files in 23 languages files that fall under my administration (7 years of products).

I require the automation framework located here:

http://documentation-stage.bne.redhat.com/docs/en-US/Internal/1/html/Alexandria/

In order to do this systematically. If the process I am following and the timeline is not acceptable to Legal Affairs, you will need to contact Paul Gampe (pgampe@redhat.com) who can provide additional guidance. 

- Mike
Comment 4 Richard Fontana 2009-01-04 23:01:52 EST
Mike,

My main requirement is getting rid of these problematic licenses (OPL+options and CC-BY-NC-SA) on (a) all documentation published from this day forward, and (b) all documentation published since January 2008, which I assume reduces the problem space considerably. I am much less concerned about pre-2008 documentation, particularly if we put up a legal notice on http://www.redhat.com/docs/manuals/ informing the public of the issue. I do not understand why that cannot be done. 

I gather that in your documentation toolchain generated trademark notices are routinely revised (presumably on a going-forward basis); the same should be true of legal notices generally.  

To be extra-clear about Red Hat policy: 

Use of the Open Publication License + "options" on Red Hat-copyrighted documentation is now prohibited, with no exceptions.  

Use of CC-BY-NC-SA on Red Hat-copyrighted documentation is now prohibited without explicit case-by-case permission from Red Hat Legal Affairs.  Such permission is very unlikely to be granted. 

A comment on Jeff's comment:

Publican and the brand packages contain Red Hat-copyrighted material and use Red Hat trademarks.  Moreover, as I understand it, they are being used to implement an automated licensing scheme for distributed Red Hat-copyrighted content.  For both of those reasons, it is Red Hat legal counsel that must have final authority on how the material is licensed, and on what sort of licensing policy they can permissibly implement.  In this case, as I think you know, I am not creating some new policy but rather implementing a specific policy of liberalizing Red Hat documentation licensing established by Mark Webbink some years ago. 

Because of special historical problems involved in Red Hat/JBoss documentation licensing, it is likely that further adjustments to documentation licensing policy, and continued close legal review, will be necessary.  (For example, we are now investigating whether there is any issue in how the OPL intersects with our trademark policy.)  Further policy changes may require changes in standard legal notices for future documentation, but we shouldn't need further changes to past documentation, which should avoid disruption. 

Thank you for your help.

Richard Fontana
Comment 5 Michael Hideo 2009-01-12 23:47:52 EST
Jeff,

We are ready to roll here. Can you put the new package together by the 21st of January?

Week of 27th of January is the respin and the push is on the Week of February 2nd.

IS/IT is on the readyline.

- Mike
Comment 6 Jeff Fearn 2009-01-15 20:22:58 EST
Will push updated publican and brand packages later today.

Note You need to log in before you can comment on or make changes to this bug.