Bug 478427 - mingetty doesn't release virtual terminal
mingetty doesn't release virtual terminal
Status: CLOSED DUPLICATE of bug 450488
Product: Fedora
Classification: Fedora
Component: upstart (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Casey Dahlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 16:36 EST by william hanlon
Modified: 2014-06-18 04:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 05:18:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description william hanlon 2008-12-29 16:36:32 EST
Description of problem:
After terminating a shell run in a vt, the vt hangs and doesn't offer a new vt login.

Version-Release number of selected component (if applicable):
mingetty-1.08-2.fc9.i386 (this is only version I see available for Fedora 10).

How reproducible:
Intermittent. I've had short periods between reboots where it seems to work ok.

Steps to Reproduce:
1. Boot to runlevel 5.
2. Press Ctrl-Alt-F<N>, where N=2-6
3. login, do something like "ls", logout
  
Actual results:
The vt shows the results of your previous commands, but doesn't spawn a new tty session. 

Expected results:
The vt should clear and show a login prompt.

Additional info:
This eats up the available vts until none are left. After I've used two (tty2 and tty3) I see the following:

loki> ps -ef | grep tty
root      2301     1  0 Dec27 tty4     00:00:00 /sbin/mingetty tty4
root      2302     1  0 Dec27 tty5     00:00:00 /sbin/mingetty tty5
root      2305     1  0 Dec27 tty6     00:00:00 /sbin/mingetty tty6

I tried running mingetty by hand by I get the following error:
Dec 29 14:20:10 loki /sbin/mingetty[11463]: tty2: no controlling tty: Operation not permitted

Not sure if this is valid thing to try though.

If anyone has any suggestions on how to troubleshoot this bug, please offer some advice, since I don't know what else to try. I don;t have much knowledge of mingetty.
Comment 1 Roman Rakus 2009-01-05 06:57:43 EST
This looks like mingetty ended right, but upstart event isn't respawned. What do you have in your /etc/event.d/tty2?
Comment 2 william hanlon 2009-01-06 12:29:05 EST
The contents of /etc/event.d/tty2:

# tty2 - getty
#
# This service maintains a getty on tty2 from the point the system is
# started until it is shut down again.

start on stopped rc2
start on stopped rc3
start on stopped rc4
start on started prefdm

stop on runlevel 0
stop on runlevel 1
stop on runlevel 6

respawn
exec /sbin/mingetty tty2


I'm running in runlevel 5.
Comment 3 Casey Dahlin 2009-01-07 05:18:15 EST

*** This bug has been marked as a duplicate of bug 450488 ***

Note You need to log in before you can comment on or make changes to this bug.