Bug 478456 - Unable to add network port to policy via system-config-selinux
Unable to add network port to policy via system-config-selinux
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 08:35 EST by Adrian "Adi1981" P.
Modified: 2009-06-26 15:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-26 15:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian "Adi1981" P. 2008-12-30 08:35:01 EST
Description of problem:
I'm running ssh server on port different than 22, so I had to modify selinux policy to add my ssh port. But every time I was trying to do that via gui, I was not allowed to do it, because of error "/usr/sbin/semanage: Wymagany jest protokół UDP lub TCP" (which means: either protocol TCP or UDP must be provided). Problem is that TCP/UDP protocol are listed in gui as combobox, and there's no other way to specify other protocols (which is correct behavior). But it doesn't matter what I'll choose from combobox, I will always get error about protocol not specified. 
Problem is with LANG variable (pl_PL.UTF-8), after 'export LANG=C' everything works perfect, with LANG=pl_PL.UTF-8 I will always get error about tcp/udp protocol not specified.

 
Version-Release number of selected component (if applicable):
policycoreutils-gui-2.0.57-14.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. export LANG=pl_PL.UTF-8
2. system-config-selinux
3. try to add new network port
Comment 1 Daniel Walsh 2009-01-04 14:25:32 EST
The problem is this language translated tcp -> TCP which is causing the application to break.

I will remove the ability to translate tcp, and this fixes the problem.

Fixed in policycoreutils-2.0.57-15.fc10

Note You need to log in before you can comment on or make changes to this bug.