Bug 478461 - Does not check and notify user if it's unable to fetch repo data..
Does not check and notify user if it's unable to fetch repo data..
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 10:29 EST by Jóhann B. Guðmundsson
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-30 14:53:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-12-30 10:29:18 EST
Description of problem:

When network connection has not been established and a user runs 
for example yum update it seems to rerun from cache and does not notify
the user that it is doing so..

Version-Release number of selected component (if applicable):

-20

How reproducible:

Always

Steps to Reproduce:
1. Turn off the network interface
2. Run yum update
3. 
  
Actual results:

Runs from cache without notifying the user that it's doing so
why it does.

Expected results:

User gets notifyed that it's running from cache and does so 
since it's unable to connect/reach the "repo" 

"Unable to reach $repo ran from cache"

Or some other informative messages that it's doing it and why..

Additional info:

Minor nuance..
Comment 1 seth vidal 2008-12-30 14:53:29 EST
It operates from a cache if the repomd.xml is within the cache timeout period. It doesn't notify the user b/c at this point it has no reason to. It's not even connected to the network.

Note You need to log in before you can comment on or make changes to this bug.