Bug 478474 - Banshee locks up transcoding files to Sansa e250
Banshee locks up transcoding files to Sansa e250
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 14:07 EST by Michael Wise
Modified: 2009-12-18 02:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:26:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 571293 None None None Never

  None (edit)
Description Michael Wise 2008-12-30 14:07:44 EST
Description of problem:Banshee locks up trying to transfer either flac or ogg encoded files to a Sansa e250.  It gets to about 97 or 98 percent of the file transcoded and the locks up.  If I mount the device as MSC, i can see an mp3 file but neither banshee nor the e250 list it.

Using banshee --debug I get

PTP: Opening session
[Warn  12:42:35.409] Caught an exception - Number overflow. (in `Mtp')
  at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_array_new_specific (intptr,int)
  at Mtp.AbstractTrackList..ctor (Mtp.MtpDevice device, IntPtr tracks, UInt32 count) [0x00000] 
  at Mtp.Playlist..ctor (Mtp.MtpDevice device, PlaylistStruct playlist) [0x00000] 
  at Mtp.MtpDevice.GetPlaylists () [0x00000] 
  at Banshee.Dap.Mtp.MtpSource.LoadFromDevice () [0x00000] 
[Info  12:42:35.583] Sync calculated for Music Library: to add: 101 items, remove 1 items; sync_src.cacheid = 79, to_add.cacheid = 87, to_remove.cacheid = 95
Sync calculated for Video Library: to add: 0 items, remove 0 items; sync_src.cacheid = 97, to_add.cacheid = 99, to_remove.cacheid = 107
Sync calculated for Podcasts: to add: 8 items, remove 0 items; sync_src.cacheid = 111, to_add.cacheid = 115, to_remove.cacheid = 123
.

Version-Release number of selected component (if applicable):

banshee-1.4.1-1.fc10.i386


How reproducible: It happens every time.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michel Alexandre Salim 2009-01-01 19:10:49 EST
Could you try

yum update --enablerepo=updates-testing libmtp\*

and see if it fixes the problem? It sounds like a libmtp bug.
Comment 2 Michael Wise 2009-01-01 20:41:29 EST
Upgraded to libmtp-0.3.5-1.fc10.i386 from updates-testing.  I get the same result and the same error.
Comment 3 Michael Wise 2009-01-07 15:57:33 EST
I installed Rockbox 3.1 on the e250.  Using banshee and the original Sansa firmware, banshee locks up on the end of converting an ogg file to mp3.  I boot into Rockbox, and my song is recognized and on the e250.  It is complete without any problems. Apparently banshee can convert the file and copy it too the e250.  It just locks up at the end.
Comment 4 Michael Wise 2009-01-27 11:16:25 EST
Upgraded to banshee-1.4.2-1.fc10.i386 from updates-testing.  Still having the same issue with lockup.
Comment 5 Michel Alexandre Salim 2009-02-10 12:38:30 EST
This could be an upstream issue. Could you file it upstream (bugzilla.gnome.org), as I don't have the hardware to test it? You can then link the bug number in the External Bugs section.
Comment 6 Michael Wise 2009-02-11 07:07:01 EST
I opened a bug upstream #571293
Comment 7 Michael Wise 2009-03-06 08:39:24 EST
Upgraded to banshee 1.4.3 from upstream.  That fixes this bug.  I am able to transfer my flac files and have them encoded on the fly with no problems.
Comment 8 Michel Alexandre Salim 2009-03-06 23:07:33 EST
Ah, good. We're planning to update F-10 and F-9 to 1.4.3 soon, I'll make sure this bug gets closed by the update.
Comment 9 Bug Zapper 2009-11-18 05:36:13 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-12-18 02:26:15 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.