Bug 478481 - qmake-qt4 seems not compile correctly some qt-plugins on 64bits arch
qmake-qt4 seems not compile correctly some qt-plugins on 64bits arch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: monkeystudio
  Show dependency treegraph
 
Reported: 2008-12-30 15:23 EST by Nicoleau Fabien
Modified: 2009-11-04 07:35 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.5.3-7.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 12:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicoleau Fabien 2008-12-30 15:23:59 EST
Description of problem:
qmake-qt4 seems not compile correctly some qt-plugins on 64bits arch

Version-Release number of selected component (if applicable):
[eponyme@FEDOBOX ~]$ rpm -qf /usr/lib/qt4/bin/qmake-qt4 
qt-devel-4.4.3-6.fc10.i386
[eponyme@FEDOBOX ~]$ qmake-qt4 -v
QMake version 2.01a
Using Qt version 4.4.3 in /usr/lib64

How reproducible:
(I'm sorry, the application (monkeystudio) concerned is quite long to compile :(  )

Steps to Reproduce:
1. On a x86_64 machine :
 Install compilation dependancies :
 # yum install qt-devel qscintilla-devel
2. download the application :
   $ wget http://monkeystudio.googlecode.com/files/mks_1.8.3.0-svn2673-src.tar.gz
   untar it
3. $ qmake-qt4
   $ make
   $ qmake-qt4 (called again to update install procedure with plugins generated)
   # make install

4. Launch the application in a terminal
   $ monkeystudio
  
Actual results:
Some errors will appear, telling for each plugin that it was impossible to load.
The application will the be launched. In "plugins > manage" menu, no plugin will be listed.
It seems that it's because plugins are compiled in 32bits. This trick will avoid this bug :
qmake-qt4 -spec /usr/lib64/qt4/mkspecs/linux-g++ (after calling make)

Expected results:
At launch, all plugins installed must be loaded properly. When application is launched, the dialog box opened with "plugins > manage" must list all loaded plugins.

Additional info:
It only appears on 64bits arch (only tested on x86_64, not on ppc64). 
Tested on other distributions (ubuntu, opensuse, debien) : this bug does not appear
Comment 1 Nicoleau Fabien 2009-08-31 12:56:01 EDT
This problem is solved with qt 4.5.2-12
Comment 2 Fedora Update System 2009-10-11 19:49:11 EDT
qt-4.5.3-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.5.3-4.fc11
Comment 3 Fedora Update System 2009-11-04 07:03:00 EST
qt-4.5.3-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2009-11-04 07:35:23 EST
qt-4.5.3-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.