Bug 478489 - Unison213 fails with message "Uncaught exception Gpointer.Null" (missing dependency)
Unison213 fails with message "Uncaught exception Gpointer.Null" (missing depe...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: unison213 (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Stephen Warren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 18:37 EST by Walter Neumann
Modified: 2009-01-29 18:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:07:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Neumann 2008-12-30 18:37:09 EST
Description of problem:Using Unison213 in gui mode give a fatal error:
"Uncaught exception Gpointer.Null"

This is caused by a missing dependency: font-schumacher-misc (which does not seem to be available as a fc10 package)

Version-Release number of selected component (if applicable):
unison213-2.13.16-11.fc10.x86_64

How reproducible:


Steps to Reproduce:
1. run unison213 in gui mode (the default) with an existing .prf file
2. 
3.
  
Actual results:
fatal error described above

Expected results:
Unison window should open.

Additional info:
This is a missing dependency: If one installs font-schumacher-misc-1.0.0.tar.gz
the the problem is resolved.

I have tested this problem and fix in fc10 x86_64 with unison213. It is probably also a problem for other platforms. Possibly also for unison227 (which I don't use).
Comment 1 Stephen Warren 2009-01-08 00:28:13 EST
That doesn't make a lot of sense; why would unison suddenly start requiring this font that it never has before? I run it in gui mode (under F9 32-bit anyway) all the time and it doesn't need that....
Comment 2 Walter Neumann 2009-01-08 08:36:13 EST
I'm running unison213 on several fc9 machines with no problem. But the fc9 installs the schumacher fonts in the package xorg-x11-fonts-misc.

The problem appeared in a fresh install of fc10 on a new machine. I googled for a solution and found the font-schumacher solution. I discovered that fc10 does not install the fonts by default. Installing them fixed the problem.

Google for: font-schumacher unison and you will find many references.
Comment 3 Stephen Warren 2009-01-08 12:23:56 EST
That makes more sense. I'll look into why the font went away...
Comment 4 Stephen Warren 2009-01-08 19:27:14 EST
I checked the content of RPM xorg-x11-fonts-misc on both F9 and F10. They are identical. The rpm .spec file doesn't have any relevant changes. Also, the .spec file does contain:

Source39: ftp://ftp.x.org/pub/individual/font/font-schumacher-misc-1.0.0.tar.bz2

and this appears to be used (I certainly see compiled versions of the sources in that file in the RPM for both F9 and F10)

Something else must be going on here...

Finally, running either unison-2.13 or unison-2.27 on F10 32-bit displays a GUI for me just fine.
Comment 5 Walter Neumann 2009-01-08 19:34:34 EST
Right -- stupid of me. xorg-x11-fonts-misc was not installed by the default F10 installation and I didn't notice. It should be a dependency for unison and that should fix the problem.
Comment 6 Stephen Warren 2009-01-08 23:36:15 EST
Great. That's an easy fix! Thanks.
Comment 7 Fedora Update System 2009-01-09 00:01:59 EST
unison213-2.13.16-12.fc10,unison227-2.27.57-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/unison213-2.13.16-12.fc10,unison227-2.27.57-10.fc10
Comment 8 Fedora Update System 2009-01-14 21:58:54 EST
unison213-2.13.16-12.fc10, unison227-2.27.57-10.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update unison213 unison227'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0439
Comment 9 Fedora Update System 2009-01-29 18:06:57 EST
unison213-2.13.16-12.fc10, unison227-2.27.57-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.