Bug 4785 - linuxconf core dumps with RH6.0
linuxconf core dumps with RH6.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-30 11:51 EDT by marko
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:29:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marko 1999-08-30 11:51:32 EDT
Ran RH5.2 on an i386-based system until August 25th with
linuxconf working fine. Upgraded from 5.2 to 6.0 and now
linuxconf crash dumps. Tried uninstalling and re-installing,
still no go. Booted the system in non-SMP mode and
re-installed linuxconf, still no go. Suggestions?

------- Additional Comments From   09/01/99 17:56 -------
I get this too.  I'm running a freshly installed RH6.0. At first
linuxconf worked OK.  At some point I installed the updated version.
Soon it began to crash when I used it to add new users.So I
uninstalled it and reinstalled the original version.  It displayed the
help panel when it first came up and then crashed. I installed the
updated version.  Same thing.  Now I can't get either version to work
at all.
Comment 1 Anonymous 1999-09-01 21:54:59 EDT
Some more info: These problems affect the NEW linuxconf

It seems to have to do with the DNS and mailconf modules.  It will
work if I take out the mailconf line from the module list - however,
many of the branches of the tree end up missing, including user
account configuration.  Also, when I go to try the DNS configurator,
it doesn't like the syntax of my named.conf file :( complains about no
master, slave, etc. also about missing semi-colons - however, both are
present, it may be that it doesn't like // end of line comments?).

Anyway to get most of the functionality of linuxconf back, I have to
remove BOTH the dnsconf and mailconf lines.

Needless to say, I have my own legacy sendmail.cf and named.conf files
which work just fine for me.  A couple of interesting points - I've
also customize my apache configuration by hand, but the apache module
does pretty well with it. So it is possible!

Another interesting facet is that if I remove the treemenu line, the
old style interface comes up just fine ---- what is the treemenu doing
that the old style interface ISN'T????
Comment 2 Michael K. Johnson 1999-09-19 19:08:59 EDT
Added Jacques to CC line so that he can investigate the mailconf
and dnsconf problems; in particular, the // comments.

Jacques, please feel free to ask for any information you need to look
into these bugs.
Comment 3 jgregor 1999-11-09 21:21:59 EST
Recently installed Redhat 6.0 with linuxconf working correctly. Then
I've been configuring things like a 2nd network card, IP firewall and
masquerade. Recently (today) I added automount maps (/etc/auto.master
and /etc/auto.net). I'm trying to mount local machine file system to
/net/<hostname>. Tonight when I run linuxconf I get a coredump. I
rebooted and I still can't run linuxconf. What should I do to further
test it?
Comment 4 Trond Eivind Glomsrxd 2000-09-13 18:29:10 EDT
This is most likely fixed in the current packages, and even in the 6.2
linuxconf packages.

Note You need to log in before you can comment on or make changes to this bug.