Bug 478515 - libvirt has unchecked dependency on dbus > 1.1
libvirt has unchecked dependency on dbus > 1.1
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-31 02:03 EST by Barry Gausden
Modified: 2010-03-16 13:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 07:59:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Gausden 2008-12-31 02:03:06 EST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6; en-us) AppleWebKit/525.27.1 (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1

Compilation of libvirt.so(?) fails due to undefined reference to dbus_watch_get_unix_fd


Reproducible: Always

Steps to Reproduce:
1.Unpack libvirt-0.5.1.tgz
2../configure
3.make
Actual Results:  
../src/.libs/libvirt_driver_nodedev.a(libvirt_driver_nodedev_la-node_device_hal.o): In function `add_dbus_watch':
/var/tmp/libvirt-0.5.1/src/node_device_hal.c:578: undefined reference to `dbus_watch_get_unix_fd'



Expected Results:  
compilation :)

Looks to be common issue re: dbus 1.0 vs 1.1. Looked for advice that libvirt 0.5 had the dbus 1.1 dependency but didn't find any.
Comment 1 Daniel Berrange 2009-01-22 07:59:59 EST
Thre was a patch merged for this issue upstream and will be in next release

#if HAVE_DBUS_WATCH_GET_UNIX_FD
    fd = dbus_watch_get_unix_fd(watch);
#else
    fd = dbus_watch_get_fd(watch);
#endif

Note You need to log in before you can comment on or make changes to this bug.