This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 478538 - PHP run on the command-line experiences a 5 second delay before exiting
PHP run on the command-line experiences a 5 second delay before exiting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-31 12:10 EST by Basil Mohamed Gohar
Modified: 2008-12-31 13:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-31 13:51:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 234927 None None None Never

  None (edit)
Description Basil Mohamed Gohar 2008-12-31 12:10:22 EST
Description of problem:

PHP, when run as a command-line application, will experience a 5 second delay aside from the time taken to execute whatever script was run.

Version-Release number of selected component (if applicable):
5.2.6

How reproducible:
Every time

Steps to Reproduce:
1. Run a PHP script from the command-line
2. Note that it takes n+5 seconds to run
3.
  
Actual results:
Scripts take 5 seconds longer to run than they should

Expected results:
Scripts should not experience any delay whatsoever

Additional info:
This appears to be new for Fedora 10, 32-bit.  I did not experience anything like this under Fedora 9.  Also, PHP run as an Apache module (mod_php5) does not seem to experience this problem.

There is a similar, if not identical, bug on Launchpad (https://bugs.launchpad.net/ubuntu/+source/php5/+bug/234927), however, the use case seems to be different than this one.
Comment 1 Basil Mohamed Gohar 2008-12-31 13:51:04 EST
Okay, I discovered, using strace, that it was trying to resolve my computer's name with a wrong hostname (beta.local instead of beta).  This appears to be a self-inflicted wound and not a real bug with PHP.  Why it would matter, I don't know, but that's not really an issue.  The delay disappeared when I corrected my local machine's hostname.

Note You need to log in before you can comment on or make changes to this bug.