Bug 478541 - [RFE] OpenOffice.org can not import svg images
[RFE] OpenOffice.org can not import svg images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 498590
  Show dependency treegraph
 
Reported: 2008-12-31 12:25 EST by Simon
Modified: 2009-05-01 07:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 498590 (view as bug list)
Environment:
Last Closed: 2009-05-01 07:02:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ooo + svg (273.38 KB, image/png)
2009-04-01 16:03 EDT, Simon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 2497 None None None Never

  None (edit)
Description Simon 2008-12-31 12:25:39 EST
Description of problem:
the openclipart package is svg only, but open office is not able to open svg’s for import them in a writer document to garnish an invitation of a sylvester party.

Version-Release number of selected component (if applicable):
Fedora 10
openclipart 0.18
openoffice.org-writer 3.0.0

How reproducible:
always

Steps to Reproduce:
1. Install openclipart
2. Install openoffice.org-writer
3. try to insert a clipart into a writer document via "insert -> picture -> from file"
  
Actual results:
it's not possible

Expected results:
it should be possible
Comment 1 Robert Scheck 2009-01-09 10:38:12 EST
Caolan, what's the problem with "%configure --with-system-libsvg"? Okay, we
maybe need to BuildRequire libsvg2 or whatever it is. Without any explanation
this is NEVER closed upstream. Simon, please re-open the bug report again.
Comment 2 Caolan McNamara 2009-01-09 10:50:15 EST
"what's the problem with "%configure --with-system-libsvg"

there isn't any such option in vanilla
Comment 3 Simon 2009-01-09 11:05:19 EST
This was my mistake.

I thought this is the solution, BUT I didn't realize that the parameter --with-system-libsvg is not for the SUN openoffice, but it is for the Novell openoffice called goo. To my surprise in other distros packages it is called openoffice.org-*, too. Sven Lankes told me that, to 

so the problem is, that sun's ooo is not able to handle svg. and i don't know if the problem will be solved in next versions.

perhaps one of this three solutions would solve this problem.

1.) generate a openclipart-png package
2.) enable svg support with an openoffice extension like this: http://extensions.services.openoffice.org/project/SVGTiny2OO
3.) switch to go-oo (Novels ooo fork)
Comment 4 Robert Scheck 2009-01-09 11:14:34 EST
Novell OpenOffice.org fork? Hopefully they maintain and drive more QA to that 
office fork than to their SLE products...otherwise I'm not amused about go-oo.
Comment 5 Simon 2009-03-17 09:14:23 EDT
I had a talk with an ooo dev at the ooo booth on Chemnitzer Linux Days

Caolan, would you please pack this
http://extensions.services.openoffice.org/project/svgimport
and activate it by default? (if possible, sorry but i don't know it, i'm just a packager in training!)

This would solve this problem and would be very cool :-)
Comment 6 Caolan McNamara 2009-03-17 11:07:26 EDT
Let's have another look at this, I'm not delighted by the extension as we'd have to build it from source and its got a fairly big java dependency chain.

Maybe its worth selectively importing in the ooo-build svg importer
Comment 7 Caolan McNamara 2009-03-18 08:42:06 EDT
Lets try that first, will be in >= 3.1.0-6.2.f11
Comment 8 Simon 2009-04-01 16:03:49 EDT
Created attachment 337642 [details]
ooo + svg
Comment 9 Simon 2009-04-01 16:06:23 EDT
the svg's are broken after import, please take a look at the attachment 337642 [details]

$ rpm -q openoffice.org-writer
openoffice.org-writer-3.1.0-8.1.fc11.x86_64
Comment 10 Caolan McNamara 2009-04-01 17:50:13 EDT
That's then "doesn't import some svg's correctly" as opposed to "cannot import svgs", hopefully an improvement of sorts
Comment 11 Caolan McNamara 2009-05-01 07:02:32 EDT
Lets make a new bug, rhbz#498590 for the specific .svg rendering problem. And leave this one as the global "enable a svg filter" issue which is done, even if not a fool-proof filter

Note You need to log in before you can comment on or make changes to this bug.