Bug 478559 - assertion pthread_setspecific(t->key, userdata) == 0'
assertion pthread_setspecific(t->key, userdata) == 0'
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libcanberra (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-31 17:46 EST by Zing
Modified: 2009-09-10 14:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:24:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of assertion (6.58 KB, text/plain)
2009-01-01 17:04 EST, Zing
no flags Details

  None (edit)
Description Zing 2008-12-31 17:46:32 EST
Description of problem:
every once in awhile, gimp will just crash on me with the following
assertion:

E: thread-posix.c: Assertion 'pthread_setspecific(t->key, userdata) == 0' failed at pulsecore/thread-posix.c:200, function pa_tls_set(). Aborting.
gimp: terminated: Aborted

(script-fu:11918): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
 
It seems to be an abort from the pulseaudio layer (although what pulseaudio has to do with the gimp I have no idea).

Unfortunately, I can't make this crash happen at will, but it's happened enough that it's very annoying.  


Version-Release number of selected component (if applicable):
gimp-2.6.3-2.fc10.x86_64

How reproducible:
Not very.  

Steps to Reproduce:
No reproducer.  I use gimp and once in awhile and gimp will crash with the above assertion.
  
Actual results:
crash

Expected results:
no crash

Additional info:
I don't use pulseaudio in my setup.  basically, i remove the pulseaudio alsa plugin package.
Comment 1 Zing 2009-01-01 17:04:16 EST
Created attachment 328047 [details]
backtrace of assertion

I caught the crash and here's the backtrace.  In this case, I had two files open and I closed one then crash.
Comment 2 Zing 2009-01-01 21:03:11 EST
ok, I did some looking around in libcanberra and set this in my environ:

$ printenv |grep CAN
CANBERRA_DRIVER=alsa

I get gnome theme sounds now, and I'm betting gimp->libcanberra doesn't call into pulse anymore (which is what i want).

At this point I don't know which component has the bug (gimp/libcanberra/pulseaudio).  I leave this to the experts.
Comment 3 Nils Philippsen 2009-08-18 08:09:00 EDT
Argh, just found this while cleaning up Bugzilla, sorry for the late reaction. Looking at the backtrace, I have a strong hunch that the problem was in libcanberra itself (don't know if there are updates already which would mitigate this issue), changing component.
Comment 4 Lennart Poettering 2009-08-19 12:43:15 EDT
Hmpf, smells as if something ran out of TLS handles. That really should not happen. Something might be leaking TLS instances.

Could you please retry with something newer than F10? F11? Rawhide?
Comment 5 Zing 2009-08-19 13:30:10 EDT
This machine is at F11+updates now.  I'll remove the canberra->alsa shim (I've been running stable that way ever since) and see what happens for the next few days.  I'll report back.
Comment 6 Zing 2009-09-09 20:09:18 EDT
So I haven't run into the assertion at all now, so this probably got fixed at some point.  Can be closed I think.
Comment 7 Lennart Poettering 2009-09-10 14:24:14 EDT
OK, closing. Feel free to reopen if this resurfaces.

Note You need to log in before you can comment on or make changes to this bug.