Bug 478566 - RFE: TZData refers to EST instead of AEST/AEDT
RFE: TZData refers to EST instead of AEST/AEDT
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-31 22:51 EST by Nigel Jones
Modified: 2015-05-04 21:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 06:17:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Jones 2008-12-31 22:51:08 EST
Description of problem:
The tzdata definition files for Australia/* provide incorrect reference to the time zone names as listed by the Australian Government and known by residents.

The problem is:

According to tzdata, EST could be (particularly at this time of the year):
GMT-5
GMT+10
GMT+11

The last two, are definitions under the Australia/* bracket, and refer to eastern Australia during standard time, and 'summer time'.

An example of the problem would be:
[njones@njones ~]$ TZ="Australia/Brisbane" date
Thu Jan  1 13:44:55 EST 2009
[njones@njones ~]$ TZ="Australia/Sydney" date
Thu Jan  1 14:45:01 EST 2009

There is no difference between the two dates, which creates confusion... "WHICH EST?!?!?!"

How is it solved?  Well the Australia Government, backs the use of appending an 'A' to the start of the timezone name to make this less confusing, it's not in legislation, but it's common sense. I refer to: http://www.australia.gov.au/Time

Under this, my expected output would be:
[njones@njones ~]$ TZ="Australia/Brisbane" date
Thu Jan  1 13:44:55 AEST 2009
[njones@njones ~]$ TZ="Australia/Sydney" date
Thu Jan  1 14:45:01 AEDT 2009

This would solve all potential issues and confusion that could be had with these timezones.

There is a patch for tzdata 2008b at: http://tedp.id.au/~ted/australia-names.diff that should be easy to adapt.
Comment 1 Petr Machata 2009-01-05 06:17:28 EST
Requests similar to yours have been discussed on upstream list in past, most recently in this thread from 08/2008:
  http://thread.gmane.org/gmane.comp.time.tz/2262

In the end, the thread doesn't bias one way or another.  The only conclusion that I can draw from that is that there's no single way of referring to Australian time (see e.g. article 2262 from Eric Ulevik: ABC NewsRadio use two different EST abbreviations).

Australian government site has been mentioned, and it has been pointed out that government has no saying in matters of DST, and that it's the right of states.

I've sent a notice about this bug report upstream, to the same thread that I link above.  Chances are the discussion will resume, and there will actually be an outcome this time.  In the meantime, I'm going to stick with upstream.

Note You need to log in before you can comment on or make changes to this bug.