Bug 478594 - Wrong BorderLayout management in JFrames
Wrong BorderLayout management in JFrames
Status: CLOSED DUPLICATE of bug 452573
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-01 13:47 EST by Steven Moix
Modified: 2009-01-09 14:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 14:04:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test program to see the behaviour (1.23 KB, application/octet-stream)
2009-01-01 13:47 EST, Steven Moix
no flags Details
OpenJDK result (3.16 KB, image/png)
2009-01-01 13:48 EST, Steven Moix
no flags Details
Expected result with Sun JDK (3.59 KB, image/png)
2009-01-01 13:49 EST, Steven Moix
no flags Details

  None (edit)
Description Steven Moix 2009-01-01 13:47:25 EST
Created attachment 328040 [details]
Test program to see the behaviour

Description of problem:
OpenJDK has a bad behavior when it comes to display standard BorderLayout-based Swing GUIs. The BorderLayout.CENTER pane is always displayed even if there is nothing in it.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-devel-1.6.0.0-7.b12.fc10.x86_64
java-1.6.0-openjdk-1.6.0.0-7.b12.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Download the attached code (Main.java)
2. javac Main.java
3. java Main
  
Actual results:
You'll see a grey zone that shouldn't exist.

Expected results:
Only a green and red zone.

Additional info:
It works perfectly (expected result) with Sun's dk-6u11 (jdk-1.6.0_11-fcs.x86_64). The same good result can be seen on any Windows or OSX machine running JDK 1.5 or 1.6.
Comment 1 Steven Moix 2009-01-01 13:48:50 EST
Created attachment 328041 [details]
OpenJDK result
Comment 2 Steven Moix 2009-01-01 13:49:14 EST
Created attachment 328042 [details]
Expected result with Sun JDK
Comment 3 Omair Majid 2009-01-09 14:04:04 EST
The problem is caused by a mistake in the calculation of the window size.

Fixed upstream:
http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2009-January/004455.html

*** This bug has been marked as a duplicate of bug 452573 ***

Note You need to log in before you can comment on or make changes to this bug.