Bug 478596 - No acpi events for sony vaio
No acpi events for sony vaio
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-01-01 14:02 EST by Simon Goodall
Modified: 2009-12-18 02:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:27:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
/var/log/messages extract (50.70 KB, text/plain)
2009-01-01 14:02 EST, Simon Goodall
no flags Details

  None (edit)
Description Simon Goodall 2009-01-01 14:02:18 EST
Created attachment 328044 [details]
/var/log/messages extract

Description of problem:

I have a Sony Vaio VGN-C2S and the "special" keys do not work (fn- based keys for brightness and suspend), nor does the power button or "lid switch". These used to work earlier on in F9, but stopped working shortly before the F10 release and still not with F10.

I believe these should all generate ACPI events through the sony-laptop module. The messages log shows acpi hooks for the lid switch and power button. There is also a /sys/class/backlight/sony/brightness which will adjust the brightness when written to.

Nothing is reported using xev or acpi_listen. Nothing appears in the logs when I press a key.

I've also tried removing the sony-laptop module (rmmod does not work with this module, so I renamed the file and rebooted) and tried the older sonypi module and this still did not work.

The xorg logs show a song vaio keys input device.

I tried an Ubuntu 8.10 live cd and this did pickup the key presses (brightness changes, logout prompt) and acpi_listen also reported events.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Comment 1 Alessio 2009-10-07 15:02:41 EDT
i cannot stand by or freeze, because the screen don't resume
Comment 2 Alessio 2009-10-07 15:04:15 EDT
also in vgn-aw21m/vgn-aw11n
Comment 3 Bug Zapper 2009-11-18 05:37:13 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 4 Bug Zapper 2009-12-18 02:27:22 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.