Bug 478598 - nash doesn't understand 'relatime' mount option
nash doesn't understand 'relatime' mount option
Status: CLOSED DUPLICATE of bug 430280
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-01-01 15:26 EST by David Zeuthen
Modified: 2013-03-05 22:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-01 16:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2009-01-01 15:26:08 EST
This bug started appearing when mkinitrd was updated to version 6.0.71-3.fc10.x86_64.

When booting, I get "mount: unable to mount /dev/root as ext3: Invalid Argument" on the console. Removing the quiet option doesn't give a lot of extra information.

FWIW, I saw this with kernel- when I updated the system. Using the new initrd on an old kernel (kernel- produced the same result as well.

# cat /etc/fstab

# /etc/fstab
# Created by anaconda on Thu Dec 18 14:37:39 2008
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
UUID=a077bf66-f6c8-4fe0-a83b-59d53cdb3efe /                       ext3    defaults,relatime        1 1
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0

I don't have any swap set up. This is a Lenovo X61 system.

Suggest to pull the mkinitrd update from the updates repo until this is resolved.
Comment 1 David Zeuthen 2009-01-01 15:34:07 EST
Turns out this is caused by the 'relatime' option which I added some time before installing a kernel. Still, it's pretty bad that nash can't handle this, even worse that the error message isn't more helpful (EINVAL can mean pretty much *anything*).

Also, at least the kernel and the standard mount command honors 'relatime'

# cat /proc/mounts |grep /dev/root
/dev/root / ext3 rw,errors=continue,user_xattr,acl,data=ordered 0 0

# mount -oremount,relatime /

# cat /proc/mounts |grep /dev/root
/dev/root / ext3 rw,relatime,errors=continue,user_xattr,acl,data=ordered 0 0
Comment 2 David Zeuthen 2009-01-01 15:35:57 EST
Also, ideally, crucial input files like /etc/fstab should be validated / sanity checked by mkinitrd before being put in the initramfs.
Comment 3 Warren Togami 2009-01-01 16:07:46 EST

*** This bug has been marked as a duplicate of bug 430280 ***

Note You need to log in before you can comment on or make changes to this bug.