Bug 478611 - Unable to burn DVD Data project running as std user
Unable to burn DVD Data project running as std user
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: k3b (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-01 23:25 EST by Glen Eustace
Modified: 2014-01-12 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-12 13:10:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
k3b debug output (1.42 KB, text/plain)
2009-01-01 23:25 EST, Glen Eustace
no flags Details
debug output (3.44 KB, text/plain)
2009-01-08 12:58 EST, Glen Eustace
no flags Details

  None (edit)
Description Glen Eustace 2009-01-01 23:25:10 EST
Created attachment 328055 [details]
k3b debug output

Description of problem:

When attempting to burn a DVD project, K3B reports an error
"Unable to determine size of resulting image file"
Works if one logs in as root.
Doesn't work if one sudos k3b ( kde permissions )

Version-Release number of selected component (if applicable):


How reproducible:
Happens everytime

Steps to Reproduce:
1. Create DVD project
2. Add some files
3. Select Burn
4. Select Burn
  
Actual results:
Error as above

Expected results:
DVD iso should be created and burned to device

Additional info:
see attachment
Comment 1 Roman Rakus 2009-01-05 06:14:02 EST
I can't reproduce it.
Can you please attach k3b debug output when logged as root?
And what says this command:  ls -lH `which mkisofs`
Comment 2 Glen Eustace 2009-01-05 14:19:33 EST
-rwxr-xr-x 1 root root 541364 2008-05-28 02:08 /usr/bin/mkisofs*

I am not currently at the machine that has the issue, will run as root tonight.

NB: Googling indicates this is not an isolated instance, Ubuntu users are having the same issue.  I am guesisng it is permissions related but on what, I don't know.
Comment 3 Glen Eustace 2009-01-05 14:20:17 EST
Opps, Attempting to create CDs also results in the same error.
Comment 4 Rex Dieter 2009-01-05 14:35:46 EST
How are you logging in?

If using kdm/gdm, these use ConsoleKit to grant the correct privledges to local devices, like burners.
Comment 5 Glen Eustace 2009-01-08 12:58:22 EST
Created attachment 328478 [details]
debug output

Sorry for the delay.  This output shows the same action, creat a CD image performed as a std user, which fails, and as root which succeeds.
Comment 6 Roman Rakus 2009-01-09 04:52:42 EST
std user:
Used versions
-----------------------
mkisofs: 2.1


root:
Used versions
-----------------------
mkisofs: 1.1.8


Hmmm...I don't know why root uses different version...
Comment 7 Steven M. Parrish 2009-01-10 09:53:12 EST
I have been unable to reproduce this on my systems.  Can anyone else reproduce?
Comment 8 Glen Eustace 2009-01-11 14:37:11 EST
I can not work out why two different versions are reported.  I can not even find a mkisofs 2.1

This was a vanilla F10 install from scratch selecting KDE and removing Gnome from the packages during the install.

(agree-6)geustace: echo $PATH
/usr/sbin:/sbin:/SF/tools:/home/geustace/bin:/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin
(agree-6)geustace: which mkisofs
/usr/bin/mkisofs
(agree-6)geustace: which genisoimage
/usr/bin/genisoimage

[root@agree-6 ~]# echo $PATH
/usr/lib/qt-3.3/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
[root@agree-6 ~]# which mkisofs
/usr/bin/mkisofs
[root@agree-6 ~]# which genisoimage
/usr/bin/genisoimage

In both cases /usr/bin/mkisofs is a symlink to /etc/alternatives/mkisofs, which is also a symlink to the same binary
lrwxrwxrwx   1 root root    20 2008-12-31 16:53 mkisofs -> /usr/bin/genisoimage*

OK, progress.  My home directory was restored from my earlier fc8 install.  I found the following in the .kde/share/config/k3brc file

                          [External Programs]
cdrdao default=/usr/bin/cdrdao
cdrdao last seen newest version=1.2.2
cdrdao user parameters=
cdrecord default=/usr/bin/wodim
cdrecord last seen newest version=1.1.8
cdrecord user parameters=
dvd+rw-format default=/usr/bin/dvd+rw-format
dvd+rw-format last seen newest version=7.1
dvd+rw-format user parameters=
eMovix user parameters=
growisofs default=/usr/bin/growisofs
growisofs last seen newest version=7.1
growisofs user parameters=
mkisofs default=/usr/bin/growisofs
mkisofs last seen newest version=2.1
mkisofs user parameters=

I will rm this file and see if that changes anything.
Comment 9 Glen Eustace 2009-01-12 13:10:04 EST
Removing .kde/share/config/k3brc seems to have resolved the issue.  There must have been some artifact in the file carried forward from Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.