Bug 47862 - FTPD will work only if connected to ISP.
FTPD will work only if connected to ISP.
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-07-08 00:01 EDT by dsamperi
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-08 01:53:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description dsamperi 2001-07-08 00:01:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.5 i686)

Description of problem:
With 7.1+ it seems that some services require connectivity to the Internet
to work
properly, even if one wants merely to talk to another machine on the local

How reproducible:

Steps to Reproduce:
1.Configure a local LAN (more than one machine) using 192.168.80.*
2.Use one machine as dialup Internet server for all others (using IP masq
3.Try to use ftp between machines on the LAN while the server is NOT
connected to
Internet. This will cause FTPD to hang forever.

Actual Results:  FTPD hangs without prompting for username and password

Expected Results:  FTPD should prompt for usename and password

Additional info:

When I try to use Sun's latest Java JDK v1.4.0 and run the demo's, they run
if I were trying to run them on a remote machine with X-windows redirected
using the DISPLAY variable, even when I run them on the local machine. This
slows down the JDK and causes font problems as well.

In general, it appears that 7.1+ RedHat forces connections to go to the
Internet and
back, slowing things down and causing other problems.
Comment 1 dsamperi 2001-07-08 00:09:54 EDT
Forgot to mention: I cannot install Borland's JBuilder4, even after upgrading to
256MB of RAM.
The installation program hangs for a long time, then the first install window
appears, but then
everything just stalls. I suspect that this is because the OS is in effect
installing this large
program "remotely" even though it is actually installed locally. I tested this
install under Linux 6.1
and it worked. Perhaps it is my X server? (Intel 815?). The relationship to the
original report
is the round-trip to the Internet, or so it seems to me.
Comment 2 Michael Schwendt 2001-07-08 01:53:29 EDT
Being just another Red Hat Linux user, I can't confirm this misbehaviour. Maybe
you have a bad default route configured?
Comment 3 Bernhard Rosenkraenzer 2001-07-08 05:32:46 EDT
The ftpd problem is almost certainly caused by a broken DNS setup.
wu-ftpd will hang for 60 seconds (hardly forever ;) ) if it can't perform a 
reverse lookup of the IP trying to connect.

The JBuilder problem doesn't have anything to do with this; If it worked in 
6.1, my guess is they're linking dynamically to libraries we no longer ship, 
such as ancient versions of libstdc++ or glibc, possibly even libc5.
Since I don't have JBuilder and it isn't free, I can't debug this; please 
report this to Borland. It's their problem.

Note You need to log in before you can comment on or make changes to this bug.