Bug 478623 - request to upgrade to new version of prboom -- prboom 2.5.0
request to upgrade to new version of prboom -- prboom 2.5.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: prboom (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
http://prboom.sourceforge.net/
:
: 478624 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 06:05 EST by Adam Sulmicki
Modified: 2009-05-06 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
release notes for prboom 2.5.0 * Limit the game to one CPU core on a multicore machine [prb+] * Fix crash when out-of-range values are used in fixed point arithmetic [prb+] * Allow the game to build without SDL_mixer, add --without-mixer option to ./configure to force this. Music support will be disabled in this case * Don't set the default game skill from the new game menu. Instead there is an option to set it explicitly in the General menu * Fix the brightness of the player's weapon * Fix linear filtering on flats in software mode * Fix crash when an unknown sprite is used with a non-zero frame number * Restore special case for trivial maps (bug #1837422) * Fix screenshots in high colour screen modes - if libpng is available at build time it will be used, otherwise a BMP will be saved * Don't process mouse input in the menus [prb+] * Always use Doom's main menu order to avoid bugs with Alien Vendetta [prb+] * Remove line of junk graphics below status bar [prb+] * Restore Boom friction and bobbing code [prb+] * Fix crash by testing for null targets in mancubus fire code pointers * Restore last known enemy check in Boom compatibility [prb+] * Animated middle textures with zero index forced [prb+] * Better handling of unrecognised demo formats [prb+] * Fix for hanging decoration disappearing in Batman Doom MAP02 [prb+] * Fix menu description: pain elementals are limited to 21 lost souls * Manual page fixes from Debian * Fix position of netgame player arrows on the automap in rotate mode * Ignore chat key presses in multiplayer demo playback and -solo-net * In deathmatch demo playback always draw player arrows on the automap * In a multiplayer demo, don't reset view to console player on a new map * Fix crash when MP3 music is being used and the player changes back to a piece of music that's already been loaded before * Avoid HOM effect on large maps such as epic.wad 5 [prb+] * Fix sound origins on large levels [prb+] * Handle demos with bad or missing headers [prb+] * Fix the colour of player 4 (red) in multiplayer * Play correct player pickup sounds in multiplayer demos * Don't allow solids to pass through no-clipping objects in Doom [prb+] * Restore Dehacked's ability to set the raisestate of a mobj [prb+] * Handle demos with a missing end marker [prb+] * Ignore switches that reference unknown textures instead of exiting * Fix crash when resetting a menu to defaults [prb+] * Fix crash when trying to play demos from Boom 2.00 [prb+] * Fix crash in multiplayer demos when there are still sounds playing on map changes (e.g. players revving chainsaws) [prb+] * Fix mouse clicks on the intermission screen being ignored * Don't eat screenshot key presses (see sf bug #1843280) * Detect Hexen-format maps and refuse to play them, instead of crashing * Fix crash when loading maps with missing player starts * The backs of switches must be pressable in any demo recorded by Boom 2.01, even those in Boom's "compatibility" mode [prb+] * Force comp_doorstuck=1 in Boom 2.01 compatibility mode [prb+] * comp_dropoff=1 was broken in MBF compatibility mode [prb+] * Restore --disable-dogs but make sure it doesn't break Dehacked * Fix desync if the user presses pause on the intermission screen [prb+] * comp_666 fixed: either cyberdemon or spider can end E2M8 or E3M8; killing a baron on E3M8 won't cause the level to end any more [prb+] * Fix broken string matching in Dehacked [prb+] * Passing --without-net to ./configure will compile the game without network support; this may help if your platform lacks SDL_net * Fix crash when reloading network savegames (bug #1590350) * Fix bug in transparency rendering caused by doing it in two places * Added high color rendering
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 00:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Sulmicki 2009-01-02 06:05:02 EST
Prboom 2.5.0 is out since 9th November 2008. Perhaps it would be worthwhile to upgrade current prboom 2.4.7 (dated: 19th November 2006)
Comment 1 Wart 2009-01-05 13:27:31 EST
*** Bug 478624 has been marked as a duplicate of this bug. ***
Comment 2 Wart 2009-05-06 00:15:26 EDT
Sorry for the delay.  2.5.0 is already in F11, but I've rebuilt it for F10 as well.

Note You need to log in before you can comment on or make changes to this bug.