Bug 478631 - Screen corruption with KMS and FUS and Compiz
Screen corruption with KMS and FUS and Compiz
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 09:47 EST by Mads Kiilerich
Modified: 2009-03-06 09:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 09:02:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.1.log (168.03 KB, text/plain)
2009-01-02 09:47 EST, Mads Kiilerich
no flags Details
dmesg (37.22 KB, text/plain)
2009-01-02 09:48 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-01-02 09:47:52 EST
Created attachment 328067 [details]
Xorg.1.log

Description of problem:

Kernel mode setting and Fast user switch combined with compiz doesn't work

01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]

Might be related to other issues reported by me or others, but I haven't found any that looked like exactly the same issue.

No xorg.conf - autodetected


Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.9.0-63.fc10.i386
kernel-2.6.27.10-167.fc10.i686 modeset
compiz-0.7.8-4.fc10.i386


How reproducible:

Probably easy on this hardware


Steps to Reproduce:

1. Logon as non-compiz user
2. Fast user switch to logon as compiz user
3. Fast user switch back to first user - works fine
4. FUS to compiz - doesn't work - screen is corrupted
  

Actual results:

Only noise is shown.

Nothing interesting (for me) in logs - most interesting is:

Jan  2 11:58:32 dev-mk kernel: mtrr: base(0xc7336000) is not aligned on a size(0x6c0000) boundary
Jan  2 11:58:39 dev-mk kernel: mtrr: base(0xc954f000) is not aligned on a size(0x6c0000) boundary
Jan  2 11:58:54 dev-mk kernel: executing set pll
Jan  2 11:58:54 dev-mk kernel: executing set crtc timing
Jan  2 11:58:54 dev-mk kernel: [drm] TMDS-7: set mode 1680x1050 16
Comment 1 Mads Kiilerich 2009-01-02 09:48:31 EST
Created attachment 328068 [details]
dmesg
Comment 2 Mads Kiilerich 2009-03-06 09:02:18 EST
That is long time ago, things have changed, and this report no longer has any value. 

Closing.

Note You need to log in before you can comment on or make changes to this bug.