Bug 478641 - Intel G45, sytem sytematically freezes after some time of use while compiz is runnig [NEEDINFO]
Intel G45, sytem sytematically freezes after some time of use while compiz is...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-02 13:18 EST by aachour
Modified: 2009-12-18 02:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:27:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
quiffman: needinfo? (aachour)


Attachments (Terms of Use)
xorg.conf (791 bytes, text/plain)
2009-02-14 08:25 EST, aachour
no flags Details
xorg log (63.58 KB, text/plain)
2009-02-14 08:29 EST, aachour
no flags Details
Xorg log with xorg.conf deleted (55.94 KB, text/plain)
2009-02-14 11:28 EST, aachour
no flags Details
Xorg log with xorg.conf deleted (2) (55.96 KB, text/plain)
2009-02-14 11:29 EST, aachour
no flags Details
Xorg log file (120.55 KB, text/plain)
2009-03-30 20:55 EDT, Richard Guest
no flags Details

  None (edit)
Description aachour 2009-01-02 13:18:55 EST
toshiba u400 14p computer
Intel GMA 4500
Fedora 10 Kernel 2.6.27.9-150


Description of problem:
The system freezes after more or less half an hour with compiz-fusion running,
nothing but 'exaCopyDirty: Pending damage region empty!' (in xorg.0.log) found in logs (messages, xorg, dmesg). 
When compiz isn't running, the system works perfectly none problem notices, but the cube-desktop plugin of compiz seems to bug: something like artefacts appears when turning the cube, je "reflecting floor" appears in a quite strange way (colors, artefacts...)
  
Actual results:
I tried to set some options given for the intel graphic chip on the compiz-fusion official website
nothing works neither setting 
        driver "intel"
        Option "XAANoOffscreenPixmaps" "true"
        Option "Capabilities" "0x00000800"
        Option "KernelModuleParm" "locked-userpages=0"
in xorg.confneither runnig compiz with the command
LIBGL_ALWAYS_INDIRECT=1 INTEL_BATCH=1 compiz --replace --indirect-rendering --sm-disable ccp & 


Expected results:
Maybe the next driver for intel G45 graphic solutions?

When the computer freezes, the mouse icon is still able to move on the screen, music is still playing, the keyboard doesn't seem to work (ctrl+alt+F1, F4, backspace)
Comment 1 Matěj Cepl 2009-01-26 12:55:19 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 aachour 2009-02-14 08:25:28 EST
Created attachment 331918 [details]
xorg.conf
Comment 3 aachour 2009-02-14 08:29:03 EST
Created attachment 331919 [details]
xorg log
Comment 4 aachour 2009-02-14 11:28:35 EST
Created attachment 331927 [details]
Xorg log with xorg.conf deleted
Comment 5 aachour 2009-02-14 11:29:08 EST
Created attachment 331928 [details]
Xorg log with xorg.conf deleted (2)
Comment 6 Richard Guest 2009-03-30 20:52:02 EDT
I suffer this problem in almost exactly the same way... The machine is for all intents and purposes still running (i.e. I can still ssh in etc.) but does not respond to any keyboard/mouse input and the desktop is completely frozen.

On my Dell Latitude E4300, which uses the Intel Mobile GM45 Express chipset.
I run X with no xorg.conf and (try to) use compiz under gnome...
I can't reliably reproduce this - it just seems to occur after an hour or so of use with compiz on - but the thing that *always* triggers the freeze for me is the cube-desktop.

I'll attach my Xorg.0.log shortly.
Comment 7 Richard Guest 2009-03-30 20:55:03 EDT
Created attachment 337262 [details]
Xorg log file

I also notice that after leaving X frozen for a while it complains about:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

and then backtraces...
Comment 8 Eric Donkersloot 2009-04-28 06:57:20 EDT
This sounds like a duplicate of bug 464866
Comment 9 Richard Guest 2009-04-28 17:13:11 EDT
My experience of this bug is definitely a duplicate of bug 464866 but I'm not sure about the original reporter.
Wanna mark it as a duplicate?
Comment 10 Matěj Cepl 2009-04-29 03:39:23 EDT
(In reply to comment #9)
> My experience of this bug is definitely a duplicate of bug 464866 but I'm not
> sure about the original reporter.
> Wanna mark it as a duplicate?  

Please, don't ... read bug 464866 comment 49.
Comment 11 Eric Donkersloot 2009-04-29 04:34:23 EDT
How is this bug different ?

Both reports handle crashes of the Xorg server on Intel hardware after using some OpenGL based application, like compiz.
Comment 13 Matěj Cepl 2009-11-17 07:01:38 EST
Switching incorrect assignees to the default one.
Comment 14 Bug Zapper 2009-11-18 05:37:54 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-12-18 02:27:43 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.