Bug 478669 - port imsettings-xfce to new xfconf backend
port imsettings-xfce to new xfconf backend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-03 01:27 EST by Kevin Fenzi
Modified: 2009-02-25 23:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 23:13:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2009-01-03 01:27:21 EST
The upcoming Xfce 4.6 version will be dropping the old mcs config setup in favor of a new xfconf framework. 

I am intending to import 4.6b2 into rawhide soon.
It would be great if you could port the imsettings-xfce plugin to the new settings model. 

Some useful links: 
http://svn.xfce.org/index.cgi/xfce/xfconf/trunk/
http://mocha.xfce.org/~kelnos/xfconf/docs-current/

Happy to try and get more info or help from upstream...
Comment 1 Akira TAGOH 2009-01-04 21:08:30 EST
Thank you for letting me know, Kevin. I'll work on this!
Comment 2 Christoph Wickert 2009-01-13 19:48:12 EST
Akira, please forgive me if this is a stupid question:
What is imsettings-xfce actually needed for? Doesn't imsettings store it's config and load it on startup? It is started automatically through the normal fdo autostart and can be configured through the the icon in the tray, so is this package really needed?
Comment 3 Akira TAGOH 2009-01-13 20:51:50 EST
That relies on xsettings to deliver IM configuration on demand for gtk+ applications at least and also uses the configuration in gconf that gnome-settings-daemon stored. which does take care of it on GNOME. since xfce has own xsettings manager and it doesn't support the key for immodule, we needed add-on to do that.
If adding the key to xfconf upstream is reasonable, that would be good. but I guess they don't like gconf at all?  Though I can put the configuration for xfce anywhere if you like. then xfconf just delivers it through xsettings. there shouldn't be additional dependencies there.

Otherwise separate component like this would be good to manage/maintain it.
Comment 4 Kevin Fenzi 2009-02-12 15:03:54 EST
Any news here?

I am going to remove imsettings-xfce from the comps-f11 group for now, so people can get groupinstalls. We can add it back in if it's done in time for f11?

Or should we be looking at an ibus solution here?
Comment 5 Akira TAGOH 2009-02-12 20:22:08 EST
Yes, please. that sounds reasonable. I'm still trying to have a certain time to work on this, but I didn't and may need more time to accomplish this.

ibus is an alternative solution for SCIM, but not imsettings FWIW.
Comment 6 Akira TAGOH 2009-02-18 05:06:19 EST
After looking at xfce4-settings source code, there seems no way to provide a xsettings key outside XFCE because xfconf doesn't link to xsettings directly as xfce-mcs-manager did. so I've submitted a patch to suport it in xfce4-settings.

http://bugzilla.xfce.org/show_bug.cgi?id=4961

FYI
Comment 7 Akira TAGOH 2009-02-19 02:31:52 EST
Should I file a bug for backporting a patch for our package, or do you want to wait for new release?
Comment 8 Kevin Fenzi 2009-02-19 16:21:58 EST
We can do either one. Thats a pretty minor patch, so if it would help you, I can apply it now. 

On the other hand, hopefully 4.6 final will be out soon, so we can pick it up then. 

Which would you prefer?
Comment 9 Akira TAGOH 2009-02-19 21:03:00 EST
Sure. I'll be ready to make a release, including this fix and others soon. if 4.6 final will be out before a mass-rebuild, I can wait for that then. otherwise backporting a patch would be appreciated. though I could just push new one without it and would be buildable. but not working properly without it.
Comment 10 Kevin Fenzi 2009-02-20 17:02:34 EST
ok. I have just built a version with the patch included. 
Let me know if you spot any problems with it or need additional work done on it.
Comment 11 Akira TAGOH 2009-02-24 21:08:29 EST
Fixed in imsettings-0.106.0-1.fc11.
Comment 12 Kevin Fenzi 2009-02-24 21:21:39 EST
Excellent. ;) 

Feel free to re-add to comps and close this when you are sure the new version is working ok.
Comment 13 Christoph Wickert 2009-02-24 21:27:22 EST
In fact you not really removed it from comps but only from the xfce-desktop group, it's still in the imput-methods group.
Comment 14 Akira TAGOH 2009-02-24 21:34:07 EST
Right because it only prevents xfce installation or upgrading.
Comment 15 Kevin Fenzi 2009-02-25 22:12:27 EST
ok, so this is back in. Shall we close this bug now?
Or is there any further reason to leave it open?
Comment 16 Akira TAGOH 2009-02-25 23:13:04 EST
No. I was about to close this. thanks for reminding me.

Note You need to log in before you can comment on or make changes to this bug.