Bug 478689 - xcb_lock.c:33: _XCBUnlockDisplay: Assertion
xcb_lock.c:33: _XCBUnlockDisplay: Assertion
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sweep (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-03 12:12 EST by Artem
Modified: 2009-03-02 12:00 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.3-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 11:59:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Artem 2009-01-03 12:12:19 EST
Description of problem:
sweep aborts after saving file with such info:
sweep-audio-editor: xcb_lock.c:33: _XCBUnlockDisplay: Assertion `xcb_get_request_sent(dpy->xcb->connection) == dpy->request' failed.
Aborted


Version-Release number of selected component (if applicable):
sweep-0.9.3-1.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.open wav file
2.do some change
3.save it
  
Actual results:
sweep crashes having file saved

Expected results:
no crash

Additional info:
Comment 1 Gérard Milmeister 2009-03-01 09:11:05 EST
Confirmed, I don't know yet how to fix this.
Comment 2 Gérard Milmeister 2009-03-01 09:22:46 EST
However, I cannot always reproduce it. Sometimes it works, sometimes it doesn't. Since the problem is connected with xcb, I suppose that sweep wants to display sometimes after it has saved, and then fails.
Comment 3 Fedora Update System 2009-03-01 09:57:23 EST
sweep-0.9.3-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/sweep-0.9.3-4.fc9
Comment 4 Fedora Update System 2009-03-01 09:57:28 EST
sweep-0.9.3-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/sweep-0.9.3-4.fc10
Comment 5 Fedora Update System 2009-03-02 11:59:31 EST
sweep-0.9.3-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-03-02 12:00:40 EST
sweep-0.9.3-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.